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FOREWORD
Welcome to CINEMA␣ 4D . The aim of this book is to introduce you gently to
many of CINEMA␣ 4D ’s powerful features, from the basic functions all the way
up to some exciting rendering and animation techniques.

This book contains two tutorials, Starting Simply and Getting Serious.

In the first project we are going to create a scene using objects, materials, textures
and lights. In creating this scene we will learn the basics of modelling and
raytracing—we’ll use many of the fundamental CINEMA␣ 4D functions, and a
few of the more advanced ones. In particular we’ll gain valuable experience
with the toolbar buttons, the Object Manager and the Material Manager. We
are going to learn how to apply textures and even how to create our own
materials from scratch.

We’ll then learn how to excite this static scene into life by using some simple
but nonetheless spectacular animation techniques.

Getting Serious again starts from scratch and in it we’ll build a model of a toy
donkey using some advanced modelling techniques including bones, NURBS
and inverse kinematics. Then, with the aid of some fire and smoke, we’ll spur
the donkey into movement and create an amusing animation.

Both tutorials are structured so that you can stop at any time and later pick up
where you left off. If you are a newcomer to 3D, we recommend that you work
through the whole of this book at your own pace—it should give you some
insight into 3D design as well as a good grounding in the use of CINEMA␣ 4D . If
you already have some 3D experience and feel confident about the subject,
you may want to skip Starting Simply and move on to Getting Serious to
experience some of the advanced features of CINEMA␣ 4D—you can always
go back when you think you need to.

We hope you will enjoy your first steps with CINEMA␣ 4D . As you work through
this book we know that all sorts of imaginative ideas for future projects will
jump into your head. At this stage you don’t know the program and you may
be unsure if what you are imagining is possible to do in CINEMA␣ 4D . We can
confidently predict that it will be simply a matter of how it is done rather than
can it be done.

CINEMA 4D XL’s Windows™ interface.

CINEMA 4D XL’s Macintosh interface.
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MAC / WIN DIFFERENCES
Mouse buttons
We recommend that you use a two-button mouse with CINEMA␣ 4D . These
can be hard to come by for the Macintosh, so if you are using a single-button
mouse and you read “...using the right mouse button”, you can simulate this
action by holding down the Command key (also called the Apple key) while
using the single mouse button.

Local menus
Every Manager window has its own “local” menu bar. In the Windows version
this menu bar is situated beneath the title bar of each window. In the Macintosh
version there is just one menu bar situated along the top of the screen; the
appropriate local menu will appear there.

In the Mac version only, in order to reduce the number of mouse miles you
have to travel when using high resolutions or multiple monitors, hold down the
Option and Command keys while clicking the mouse button to open the local
menu for the active window as a pop-up menu.

Dialog pages
In some dialogs you can switch between several pages of options. In the Windows
version this follows the tabbing principle—the page titles are on tabs along the
top of the dialog. In the Macintosh version, switching between pages is achieved
by selecting them from the pop-up menu at the bottom left of the dialog.
Alternatively you can use the arrow buttons to flip through the pages.

Image versus File
To load a texture when you are in the Edit Material dialog, click the File button
if you are using a Macintosh or click the Image button if using a Windows
computer. We will use the term “File button” throughout this book.

The Windows version allows you to attach
the toolbars to either the inside or outside of

windows.

The Macintosh version allows you to pop-up
local menus by holding down the Option and

Command keys while clicking the mouse.

The Macintosh version lists dialog pages in
pop-up menus at the foot of dialogs.

The Windows version lists dialog pages on
tabs along the top of the dialog.
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CREATING A SCENE

At this early stage we don’t want to burden you with advanced drawing
techniques, so the scene we are going to create is going to use simple objects
that we can create quickly and manipulate easily. Simple objects or not, we can
use CINEMA 4D to turn mundane shapes into “living” 3D objects.

This is the scene we are about to create.
CINEMA 4D will do all the hard work for us.
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We will create a scene that has a floor and a sky. On the floor we will sit a plinth
and on the plinth we will sit a crystal ball. In front of the plinth we will stand
some metallic lettering. Using materials, textures and lighting we will discover
that you can turn a pig’s ear into a silk purse.

The sphere
1 After running CINEMA 4D, create a sphere by selecting Perfect Sphere from

the Objects>3D-Object menu. (Mac: If you cannot see an Objects menu
title it will be because the Scene Editor window is not active. Click in the
Scene Editor to activate its local menu.) Press OK to accept the default
values.

A white wireframe sphere will appear in the Scene Editor, surrounded by a red
cube—the red cube is CINEMA␣ 4D ’s way of letting you know which object is
currently selected. Notice that the sphere has also appeared as an entry in the
Object Manager. Don’t worry about the meaning of the little icons at this stage,
you can read all about them later in the reference manual.

The wireframe display has the advantage of being very quick, but pretty soon
you’ll discover that you need to see a solid representation of objects in order to
get a better feel for what you are doing. CINEMA 4D has several display modes,
but the one you’ll probably use most while working on your scenes is Gouraud
Shading.

This section will take about
10 minutes to complete.

In the Objects>3D-Object sub-menu you’ll
find the basic building blocks from which 3D

objects are created.
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2 Select Gouraud Shading from the View>Display Mode menu. (Mac: If you
cannot see a View menu title it will be because the Scene Editor window is
not active. Click in the Scene Editor to activate its local menu. This is the
last time we are going to remind you that each window has its own local
menu.) Alternatively you can click on the Display button in the View palette
and select Gouraud Shading.

The wireframe sphere will turn into a solid, shaded white sphere. From now
on, when the Scene Editor is at rest—when you aren’t editing the scene in
other words—CINEMA 4D will quickly use Gouraud Shading to change
wireframes into solids. If at any time you want to force CINEMA 4D to shade
the scene—say because you’ve interrupted CINEMA 4D so that the scene is
only partly shaded—then you can use the View>Redraw command to make
CINEMA 4D refresh the Editor window.

Now we want to raise the sphere a little so we can put a plinth underneath it.
Moving an object accurately is very difficult to achieve in the 3D view, so let’s
change to the 4-Way-View (4T) view in which it is much easier to move objects.

3 Press the 4-Way-View button.

The Display button.

There are several display options. Wireframe
is the fastest, but Gouraud shading gives you

a better feel for the scene.
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The Scene Editor changes so that you now have four views of the object—the
3D view (top left), a view from above (top right), a view from the side (bottom
left), and a view from the front (bottom right). Because the sphere is completely
symmetrical, the above, side and front views of it look the same, but notice that
the axes are labelled differently.

In CINEMA␣ 4D , Y is the vertical axis (up-and-down), X is the horizontal axis
(left-and-right), and Z is the depth axis.

Let’s move the sphere.

5 Press the Model Tool button (next to the Camera Tool button).

If we don’t press the Model Tool button then we will end up moving the camera
instead of the object. As all we want to do is raise the sphere—move it along
the Y axis in other words. We can ensure that we don’t move it along either of
the other two axes by locking them while we perform this operation.

6 Press the X axis and Z axis buttons so that the buttons appear raised or
“switched off” (the symbolic lamp turns red).

7 Click in the bottom left quadrant of the Scene Editor (the side view) and
while holding down the (left) mouse button push the mouse away from
you until the bottom of the sphere is about halfway to the first grid line
above the Z axis.

The Axes buttons, with X and Z locked or
“switched off”.

The 4-Way-View (4T) button.

The Model Tool button.
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Moving the mouse while holding down the mouse button is called “dragging”
the mouse. From now on we will use that term.

Notice that the 3D and front views also move as you move the object in the
side view. The from-above view doesn’t change because the object is not moving
along either the Z or X axes, just the Y axis.

OK, that’s it, we’ve finished with the sphere for the moment. Next we’ll create
the plinth, but before we do that, let’s save what we’ve got so far.

8 Select Save from the File menu, select a folder, give your work a filename,
press the Save button.
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The plinth
For the crystal ball’s plinth we are going to use an ordinary cube object and
flatten it a bit. Later we’ll give it a texture (as we will everything else), but for
the moment all we are concerned with is creating the various objects that
comprise our scene.

1 Hold down the Shift key and select Cube from the Objects>3D-Object
menu.

We now have a cube in our scene and it is sitting under the sphere. Let’s
reshape the cube.

2 Ensure that the cube is the selected object (click on its name in the Object
Manager).

3 Ensure that the Model Tool button is selected.

4 Press the Scale button.

As all we want to do is squash the cube a little—scale it along the Y axis in other
words—once again we can lock the X and Z axes.

5 Press the X axis and Z axis buttons so that they appear raised or “switched
off”.

6 Click in the 3D view and drag the mouse slowly to the left until the height
of the plinth is about one-third its width. (Remember, dragging means
moving the mouse while holding down the mouse button.)

Now we’ve got the shape we want, but it is not positioned correctly. We need
to raise the plinth so that it sits smack on the X axis (which is where our floor
will be).

7 Press the Zoom button and click in the front view (bottom right) just above
and to the left of the top left corner of the plinth. Drag the mouse just
below and to the right of the bottom right corner of the plinth. Then let go
of the mouse button.

We have zoomed in on the plinth so that it is easier for us to position it accurately
using the mouse. Notice that the 3D view remains as it was; this is because the

Holding down the Shift key while selecting
an object from the 3D-Object sub-menu is a
timesaving technique to bypass the object’s

parameters dialog.

This section will take about
5 minutes to complete.

The Zoom button.

The Scale button.
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3D view is always the view as seen from the camera, and as the camera position
hasn’t changed, neither has the 3D view changed.

8 Click on the Move button.

9 If they are not already locked, press the X axis and Z axis buttons so that
they are locked.

10 Click in the front view window (bottom right) and drag away from you
until the white line of the plinth’s base is sitting on the X axis.

OK, so now the plinth is almost where we want it and the sphere should be on
top of the plinth and slightly sunk into it. In a moment we are going to rotate
the plinth and the camera view into the positions we want them, but as rotating
is new to us and we might muck it up, this seems like a good time to save our
work so we can revert to it when we do muck it up. Let’s zoom out first...

11 Press the Zoom button and click in the front view while you hold down
the control-key. With the control-key and mouse button held down, drag
the mouse down and to the right so that the box you are dragging is about
the same dimensions as one of the grid squares. Then let go of the mouse
button and control-key.

When zooming out, the smaller the box you drag, the further out you zoom.
Now let’s save.

12 Select Save from the File menu.

Rotating the plinth
The plinth has got one of its edges facing us and what we really want is one of
the faces pointing towards us. We could move the camera, but it’s quicker to
rotate the plinth.

1 In the Object Manager, ensure that the plinth (cube) is the selected object..

2 Ensure that the Model Tool button is selected.

3 Select Coordinates Manager from the Window menu.

To see more of your scene in the 4T views,
ctrl-drag a small box with the mouse (drag

while holding down the Ctrl key).

Positioning objects by mouse is made easier if
you zoom on the area in question.

This section will take about
3 minutes to complete.

Note that the managers are all on easy-to-
remember keyboard short-cuts.

The Move button.
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4 In the Coordinates Manager, change the value in the Direction H field (the
object’s heading) from 0 to 45 and press the Apply button.

The plinth rotates about its Y axis by 45 degrees and ends up facing towards the
camera. We used the Coordinates Manager to rotate the plinth simply to show
that there is more than one way to skin a cat... (er, better make that peel a
potato if you’re a vegetarian.)

If you prefer, you can rotate objects with the mouse using the same techniques
we are about to use to rotate the camera view.

You can close the Coordinates Manager window now if you like.

OK, so let’s adjust the camera position. We want to adjust it so that we are
looking at the scene from eye level rather than the “slightly up in the air” view
that we currently have.

5 Press the Camera Tool button.

6 Press the Rotate button.

7 Lock (switch off) the X axis and the Z axis, leaving the Y axis switched on
(unlocked).

8 Click in the 3D view and drag towards you until the grid lines that are
farthest away from you fall just below the shoulders of the plinth.

If you know exactly where you want your
object to be, the Coordinates Manager is very

often the best tool to use.

The Rotate button.

The Camera Tool button.
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And we’re done rotating. Well, for now at least. Next it’s about time we created
our floor and sky objects. Better save first, though...

9 Select Save from the File menu.

Sky and floor
The Sky and the Floor are Special Objects.  Although their moving, scaling and
rotating abilities are very limited, they are very useful. You’ll see...

1 Select Sky from the Objects>Scene Object menu and confirm the dialog.

Nothing apparently happens in the Scene Editor, but you’ll notice that an entry
for Sky has appeared in the Object Manager. The Sky is an object that totally
encloses our scenes like a big globe. Just as the real sky is all around the Earth
(that is, not just above us), so our scene’s sky is all around the scene. Later we
will put some clouds in our sky.

2 Select Floor from the Objects>Scene Object menu and confirm the dialog.

Again, nothing apparently happens in the Scene Editor, but you’ll notice that
an entry for Floor has appeared in the Object Manager. The Floor is an object
that sits on the grid you can see in the 3D view and stretches to infinity in all
directions. Later we will lay some shiny linoleum on our floor.

Right, we have just one more object to create, the text that we’re going to
stand on the floor in front of the plinth. We’ll be spending a little time on this
Text object so now might be a good time to save what we’ve done so far and go
put the kettle on.

Placing the text
Like Sky and Floor, Text is a Special Object. What we are going to do is place
some 2D text in the scene, then make CINEMA␣ 4D create a 3D version of that
text using a technique known as “extruded splines”.

The word “splines” is just the technical term for the outlines of an object.
Extruding is a term borrowed from the manufacturing industry—it’s the process
used to create plastic and metal mouldings by forcing the material out under
pressure from a shaped die. So our 2D object is the die that CINEMA␣ 4D will
use to produce the moulding—the 3D object, that is.

This section will take about
2 minutes to complete.

This section will take about
4 minutes to complete.

Although we have placed Sky and Floor
objects in our scene, nothing appears to have
changed. Rest assured the sky and floor are

there, as you can see in the Object Manager.



22 CINEMA 4D QUICKSTART

1 Select Text from the Objects>Splines menu.

2 Type some text into the dialog that appears (we have used the text “MYSTIC
PEG”) and press OK.

Our text will appear in the scene, flat as a pancake. It’s also running right
through the plinth, but don’t worry about that because we’ll be throwing away
this text object in a while. Now let’s get CINEMA␣ 4D to extrude the splines of
the text.

3 Select Spline Object>Extrude Object from the Objects menu.

4 In the dialog that appears, go to the Cover Surfaces page (Caps page under
Windows) and select Close and Round for both the Start and the Finish of
the text, and then press OK.

After a very short delay while CINEMA␣ 4D does its sums, a new object appears
in our scene—a 3D version of the text. If you look in the Object Manager you’ll
see that an Extrude Object entry has been added above the Text Object entry.
We don’t need the Text Object any longer, so let’s get rid of it.

Two-dimensional text can be added to your
scenes as easily as this.

To turn 2D text into 3D text, the text object
has to be “extruded”.
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5 Click on the Text name in the Object Manager to select the object.

6 Select Delete from the Edit menu. (Or simply press the Del key on your
keyboard.)

And while we’re tidying up, let’s move that Extruded Object down the list and
give it a more sensible name.

7 Click on the Extrude Object name in the Object Manager.

8 Drag towards you until the mouse pointer is below Sphere in the list, then
let go of the mouse button.

The Extruded Object entry will move to the foot of the list. We could just as
easily have dropped the Extrude Object anywhere else in the list. Give it a try.

Where an object is in the list isn’t important to the scene, but often when you
have many objects in a scene you may want to structure your object list in a
logical manner—drag-and-drop is how you do it.

Always keep your scenes uncluttered by
deleting objects that are no longer needed.



24 CINEMA 4D QUICKSTART

9 Select Rename Object from the Function menu. (Or simply double-click
on the Extrude Object name in the Object Manager.)

10 Give the object a new name (we called ours “Mystic Peg”) and press OK.

Positioning the text
To position the text we can use the techniques we learnt earlier when positioning
the sphere and cube.

1 Ensure that the text is the selected object (click on its name in the Object
Manager).

2 Click on the Model Tool button.

3 Click on the Move button.

4 Ensure that the X, Y and Z axis buttons are switched on.

5 Click in the side view of the Scene Editor (bottom left) and drag the mouse
away from you until the base of the text is sitting on the Z axis.

6 Open the Coordinates Manager and change the H field under Direction to
45 and press Apply.

7 Click in the from-above view (top right) and drag the object down and to
the right a bit until the text is slightly in front of the plinth.

As you perform these operations you will see the text moving around in all four
quadrants of the Scene Editor. It is possible that when you have positioned the
text in front of the plinth that you cannot see its full width in the 3D view. If you
do not want to move the camera further away (so all the text comes into view)
you can scale the text so that it becomes narrower and/or shorter.

8 In the Coordinates Manager, choose Scale from the pop-up at the bottom-
centre of the dialog, alter the X field to be 0.5 and press Return. (Pressing
the Return key has the same effect as pressing the Apply button.)

The text will become half the width it was—that is 0.5 times as big. You can
always recreate the original size of the object by typing 1 in the scaling-fields.

This section will take about
8 minutes to complete.

The easy way to alter the direction an object
is facing is to change its Heading (H) in the

Coordinates Manager.
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Play around with the Scale X and Y fields until you are happy with the size of
your text. (You did save before you started playing, didn’t you?)

OK, that’s it, all our objects are in place. Now comes the fun part, covering our
objects with materials and textures so that they look more realistic.
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APPLYING MATERIALS
Applying a material to an object is like putting a tightfitting cover on a sofa. The
difference is that in CINEMA␣ 4D you can change the appearance of the material
without changing covers. To start with the material is plain. The simplest thing
you can do to a material is give it a colour, but by selecting various options and
applying textures you can make materials look like any material you want—
wood, metal, leather, plastic, glass, water, smoke... literally anything!

The sky
We’ll start with the sky object. What we want is a blue sky with some fluffy
white clouds floating in it.

1 Open the Material Manager (from the Window menu) if it isn’t already
open.

2 Click in the Material Manager and select New Material from the File menu.

A button (named New) with a shaded white sphere on it appears in the Material
Manager. As we adjust the material, the appearance of the sphere will change
to give us a rough idea of what the material looks like.

3 Double-click on the New material to open the Edit Material dialog.

The Edit Material dialog has quite a few pages. Currently we are looking at the
Colour page. We will be visiting most of the other pages as we make and apply
materials to our various objects.

4 Click on the File button and use the file selector to find and open a picture
named “Clouds.tif” in the Tex/Basics folder.

A thumbnail of the picture appears to the right of the filename. We are going to
“paint” this picture all over the Sky object.

5 Under the Colour heading, change the S value to be zero, then click OK.

The R, G, B and S sliders are used to give the material a colour. We don’t want
our material to have a colour (because the picture we have opened uses the
correct colours for a sky) so we have set the strength of the material to zero,

Materials are represented in the Material
Manager by a shaded sphere. The

appearance of the sphere will change to
reflect the properties of the material.

This section will take about
9 minutes to complete.
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which means no colour. If we hadn’t opened a picture then the material would
appear black—black being what we see when there is an absence of colour—
but as we have opened a picture then what we see is the picture.

Now then. The picture we have opened is only small and the Sky is big, way
bigger than the picture. And, of course, the picture is flat and rectangular whereas
the Sky is curved. How does CINEMA␣ 4D completely fill a big round hole with
one little square peg?

Tiling is the answer. CINEMA␣ 4D uses the picture over and over again, distorting
it where necessary, until it has covered the entire object. The important point
here is that where CINEMA␣ 4D has joined the tiles, seams may show if the
picture isn’t designed to tile seamlessly (the “Clouds.tif” picture is).

6 Click on the New material, select Rename from the Function menu and
give this material a sensible name (like Sky, for instance).

7 Position the mouse pointer over the newly-named Sky material, hold down
the shift-key and the (left) mouse button, drag the pointer over the Sky
entry in the Object Manager, then let go of the mouse button.

We have just used the drag-and-drop technique to apply the material to the
object. Alternatively, if we felt like doing it the long way, we could have clicked
on the object name in the Object Manager, clicked on the material in the
Material Manager, and then selected Apply from the Function menu. Note that

Always give your materials sensible names.

In the Object Manager materials are
represented by an icon of a sphere with a

little square of colour on it.
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holding down the Shift key while selecting this command circumvents the dialog
and applies the command with default values.

Right, hold on to your horses and don’t get too excited here because it won’t
be anything to write home about, but we are going to render the scene.

8 Click in the Scene Editor and press the Render in External Window button.

The scene will start to render and you will see the blue of the sky. Not very
good, is it? Doesn’t look much like a cloudy sky to us. There’s a reason for that,
and we can fix it.

9 Close the render window, and in the Object Manager, to the right of the
Sky entry, double-click on the icon that represents the material properties—
the one that looks like a miniature of a material thumbnail in the Material
Manager.

The Texture dialog that appears contains some fairly advanced features and
this Quickstart book is not the right place to describe them, so we’ll concentrate
on just the two settings that we need to adjust in order to put the clouds back
into our sky.

To understand what we are going to do you need to understand what
CINEMA␣ 4D has done with the picture we’ve used as a texture for the sky .
Right now, CINEMA␣ 4D is doing its level best to tile the sky using as few “copies”
of our picture as possible by stretching it out. So the clouds in our picture are

Double-click on the material object property
in the Object Manager to edit a texture.

The Render in External Window button.
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actually there, washed out a bit by the stretching process, and by the looks of it
mostly in another part of the sky.

Now then, because we can put lots of copies of this particular picture together
like a jigsaw and not see the joins, we can ask CINEMA␣ 4D to use lots of copies
instead of stretching out a single picture. We do this by specifying how much of
the sky should be covered by one copy of the picture.

10 In the Texture dialog that we have open, change the values in the X and Y
Length fields from 100 to 20. Activate the Seamless option with a checkmark
and press OK.

We have told CINEMA␣ 4D to cover only 20 per cent of the sky with one picture
instead of 100 per cent of the sky with one picture. Let’s render it again so we
can see the difference.

11 Click in the Scene Editor and press the Render in External Window button.

There we go, that looks more like a sky. If you change the percentages to 10 or
5 the sky will become even cloudier, but although you won’t be able to see any
joins you will begin to see a regular pattern of clouds, and that would destroy
the illusion. Try it!
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When you are using tiled pictures for textures, keep a weather eye out for this
type of regular pattern; one way to destroy the pattern is to enlarge those X and
Y Length percentages.

OK, that’s it for the sky. Time to save and move on to the floor.

The floor
For the floor we are again going to use a picture as a texture, but we are going
to give the floor some properties so that it looks like shiny linoleum. The first
few steps of this process are the same as they were for the sky.

1 Open the Material Manager if it isn’t already open.

2 Click in the Material Manager and select New Material from the File menu.

3 Double-click on the New material to open the Edit Material dialog.

4 Click on the File button and use the file selector to find and open a picture
named “Checks.tif” in the Tex/Basics folder.

The checks are black and white. We don’t like black and white checks, but we
do like blue and white checks.

This section will take about
6 minutes to complete.
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5 Under the Colour heading, change the R and G values to 0, leaving the B
and S values at 100. (Don’t close the dialog yet.)

Notice that the material thumbnail in the top right of the dialog now shows the
texture to have blue and white checks. Right, lino is shiny—it reflects things in
other words—so let’s make it shiny.

6 Go to the Reflection page.

The settings on this page all have an effect on how a material should reflect
light. But only if reflections are turned on.

7 Click in the little white box to the left of the Reflections option so that a
tick appears.

We have now switched on reflections for this material and we can see the
effect this has had on the material thumbnail. Much too shiny, let’s tone it
down a bit.

8 On the Reflection page, adjust the strength of the colour (the S slider under
R, G and B) from 100 to 30.

Better. That’s the floor finished. All we have to do now is give the material a
sensible name and apply it to the Floor object.
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9 Click OK in the Edit Material dialog and then select Rename from the
Function menu. Give the material a sensible name (like Lino for instance).

10 Apply the floor material to the Floor object by dragging the material’s icon
on to the Floor object in the Object Manager.

Go on, we know you’re busting for it... have a quick render to see what the
scene looks like now. But save first!

The plinth
Let’s make the plinth have a black plasticky kind of PVC type texture.

1 Open the Material Manager if it isn’t already open.

2 Click in the Material Manager and select New Material from the File menu.

3 Double-click on the New material to open the Edit Material dialog.

4 In the Colour page, set the strength of the colour to zero.

5 Go to the Bump page.

This time, instead of using a picture to give our material a texture we are going
to use something called a bump map—so named because it gives a material a
bumpy kind of texture.

This section will take about
4 minutes to complete.



36 CINEMA 4D QUICKSTART

A bump map is actually a picture, but instead of the actual picture being used
for the texture the shade differences in the picture are used in combination
with the other settings for the material. For this reason bump maps are normally
created in shades of grey, but any shade of any colour can be used, or even a
normal colour picture.

For bump maps to work we first have to switch on that feature for the current
material.

6 Click in the little white box to the left of the Bump option so that a tick
appears.

7 Press the File button and use the file selector to find and open the bump
map named “Bump13.tif” in the Tex/Basics folder.

8 Adjust the Strength setting to read 20%.

The appearance of the texture in the material thumbnail hasn’t changed at all
yet. That’s because our material is not reflecting any light. We don’t want full
reflections on this material, all we want is highlights where the texture wobbles
up and down.
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9 Click in the little white box to the left of the Highlight option so that a tick
appears. (Note that we don’t have to go to a function’s page just to switch
on that function, only when we want to alter settings for that function.)

The material thumbnail now has some texture. Does that look like a black
plasticky kind of PVC type texture to you?

10 Click OK in the Edit Material dialog, give the material a sensible name (like
Plastic for instance), and apply it to the Cube object.

So much for the plinth. Next we come to the... tch, go on then, have a quick
render to see what it looks like. But do save first!

Didn’t look particularly good, did it? Don’t fret, all will become clear soon.

The crystal ball
A crystal ball is, quite naturally, made of crystal, so that’s the type material we
have to create for it. It’s actually very easy to create a glass or crystal material
because CINEMA␣ 4D does all the hard work for us.

1 Open the Material Manager if it isn’t already open.

2 Click in the Material Manager and select New Material from the File menu.

3 Double-click on the New material to open the Edit Material dialog.

Our scene is beginning to take shape.

This section will take about
3 minutes to complete.
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4 In the Colour page, set the strength of the colour to zero.

Remember, a colour strength of zero means “colourless” not “black”. The
material will appear black unless we do other things to it, but that’s because it
lacks colour, not because it has been “painted” black.

Now we need to turn our colourless ball into a crystal one.

5 Go to the Transparency page.

6 Click in the little white box to the left of the Transparency option so that a
tick appears.

The material is now transparent. In fact it is so transparent that we can’t see it.
That’s easily fixed.

7 Still on the Transparency page, adjust the strength of the colour to 70.

Now the texture shows up in the material thumbnail as light grey. Crystal balls
are highly reflective and will have highlight spots when lights are shone on
them, so let’s turn on those options.

8 Go to the Reflection page.
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9 Click in the little white box to the left of the Reflections option so that a
tick appears.

10 Adjust the strength of the colour to 25 to tone down the reflections.

11 Click in the little white box to the left of the Highlight option so that a tick
appears.

The material thumbnail now looks very much like a crystal ball. We may need
to tweak it later, then again we may not... For the moment let’s settle for what
we’ve got.

12 Click OK in the Edit Material dialog, give the material a sensible name (like
Crystal for instance), and apply it to the Sphere object.

If you render the scene now you’ll be fairly pleased with the results, but it’s far
from perfect. Perfection will come later, but first we must give a material to our
final object, the text in front of the plinth.

Don’t forget to save before starting on the next stage.

Now we can see into our crystal ball.
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The text
For the crystal ball we created our own material from scratch, without the help
of pictures or bump maps. We are going to do the same thing for the text to try
to give it a shiny gold metallic appearance.

1 Open the Material Manager if it isn’t already open.

2 Click in the Material Manager and select New Material from the File menu.

3 Double-click on the New material to open the Edit Material dialog.

4 In the Colour page, set R to 100, G to 90, B to zero and S to 75.

That’s our basic gold colour. Now, the thing about gold, so people say, is that it
kind of glows on you. It doesn’t actually glow, but people are always saying
how gold seems to have its own light almost as if in a pitch black room you
would still be able to see gold. We can do that.

This section will take about
5 minutes to complete.
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5 Go to the Luminance page.

6 Click in the little white box to the left of the Luminance option so that a
tick appears.

7 Set the R value to 10, G to 10, B to 0 and leave S on 100.

We have now set up the material so that even in a pitch black room with
absolutely no light anywhere, we will still be able to see it as this very dark olive
green kind of colour.

Don’t think of luminance as a light. It isn’t. Although the material is luminous, it
is emitting no light so it will not illuminate the scene in any way. The material is
luminous, not illuminant.

Lastly, to make the material appear metallic we need to make it shiny and give
it highlights.

8 Go to the Reflection page.

9 Click in the little white box to the left of the Reflections option so that a
tick appears.

10 Set the R value to 75, G to 30, B to 30 and S to 50.
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What we have done here is limit the colours that get reflected. Think of a silver
mirror. If you look in that mirror in normal daylight you’ll see yourself reflected
in that mirror pretty much as you look in real life. If you have a red nose, your
reflected nose will be red.

Now look in a gold plated mirror. Will your nose still be red. No, it won’t, it’ll
be a “goldy-red” colour. The gold doesn’t reflect the entire spectrum of colours,
which is why it looks gold to us and not silver, or pink, or tartan or whatever.

So we have set the sliders to reflect the maximum amount of each colour that
can be reflected. One way of visualising this is to think of the entire spectrum
being reflected, but only up to the level each slider is set to.

Setting our maximums to this murky red colour is ultimately what will give our
material a realistic gold appearance.

But it won’t look right without highlights...

11 Go to the Highlight page.

12 Click in the little white box to the left of the Highlight option so that a tick
appears.
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13 Leave the Mode as Plastic (in this case we think it just happens to look
better than the Metal mode), but change the Width setting to 15 so that
the highlights aren’t too big, more like sparkles.

14 Click OK in the Edit Material dialog, give the material a sensible name (like
Gold for instance), and apply it to the Mystic Peg object (or whatever else
you called the text).

And we’re all done with materials. Don’t bother rendering the scene because
we’ll be doing that in a minute anyway. Save your work and let’s take a break.
When we come back we’re going to spend some time seeing the light.
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LIGHTING THE SCENE

If you haven’t already rendered the scene, do it now... Like it? It’s a fairly pleasing
scene, but the lighting’s all wrong. The only light at the moment is that being
provided by a light that CINEMA␣ 4D automatically places behind the camera—
you can think of it as an auto-flash, and, like a real auto-flash, if we light the
scene ourselves the auto-flash won’t flash. So let’s light the scene.

We’ll start with some ambient light—a general light source that will emit light in
all directions—and we’ll position it up in the air above the crystal ball.

1 Select Light from the Objects>Scene Object menu.

2 Rename the object to Ambient Light.

Let’s give our ambient light some character rather than have it a bland and
unnatural white.

3 Set the R value to 100, G to 60, B to 50 and S to 100.

This section will take about
4 minutes to complete.

Light is a Scene Object in the Objects menu.
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And let’s reduce its strength a little by forcing the light to decrease gradually
over a distance. This ought to add some shading to our floor.

4 Click in the little white box to the left of the Decrease option so that a tick
appears.

5 Press the OK button.

The Ambient Light object appears in the Object Manager and in the scene we
can see it at the intersection of the X, Y and Z axes. It’s not a lot of good to us
there, so let’s move it.

6 Ensure that the Move button is selected.

7 Ensure that the Model Tool button is selected.

8 Ensure that Ambient Light is the selected object.

9 Open the Coordinates Manager if it isn’t already open.

Lights can have many properties. For this
scene we are starting with a simple, soft red
light whose strength decreases with distance.
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10 Click in the side or front view and drag the Ambient Light up until the Y
Position coordinate in the Coordinates Manager is about 500.

Remember, you can lock off the X and Z axes to stop the object wandering off
in the wrong direction, or simply reset the X and Z Position coordinates to zero
in the Coordinates Manager.

11 Press the Render in External Window button.

What a difference, eh? And it’s going to get a lot better still.

More light
The scene is well lit now, but the text looks a bit drab. How about if we stick a
spotlight on it?

1 Select Light from the Objects>Scene Object menu.

2 Rename the object to Spotlight.

3 Ensure that the R and G colour sliders are set to 100, then set the B colour
slider to zero so that the spotlight is bright yellow.

4 Turn on the Decrease and Spot options (click the white box to the left).

The default Spot Angle is a bit narrow for our purposes, so let’s widen it.

5 Set the Spot Angle value to 45 and press OK.

The Spotlight object appears in the Object Manager, and in the Scene Editor
you can see the Spotlight as lines radiating from the intersection of the X, Y and
Z axes. Now we have to move it and point it at the text.

BEFORE
LIGHTING

AFTER
LIGHTING

This section will take about
4 minutes to complete.

To create beams of light that widen from a
narrow point, you need to switch on the
Spot option and set the required Angle.
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6 Ensure the Move and Model Tool buttons are selected.

7 Switch off the X and Z axes (leaving the Y axis switched on), then drag the
Spotlight up (the Y axis) until it is at about the same height as the top of the
crystal ball.

8 Switch on the X axis, switch off the Y and Z axes, then drag the Spotlight off
to the right of the scene until its X Position coordinate in the Coordinates
Manager is at about 500.
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Good. So our Spotlight is in position. But it isn’t pointing at the text. We could
do this with the mouse (using the Rotate and Model Tool buttons) but only if
we really enjoy doing things the hard way. Which we don’t, so we’re going to
do it the easy way.

8 Ensure the Spotlight is the selected object, then select Align To Object
from the Tools menu.

If it helps, think of Align To Object as meaning “point at object”. You’ll use this
feature a lot with lights. The dialog that opens wants to know at which object it
should point the spotlight.

9 Type the letter “c”.

Below the text field CINEMA␣ 4D will display the name “Cube”, which is our
plinth of course. The text is directly in front of the plinth and if we point the
spotlight at the plinth (cube), the text should fall within its beam as well. This
way we get to spotlight the plinth and the text with just the one light.

10 Press OK.

CINEMA␣ 4D will grab hold of the spotlight and point it at the Cube object.
And that’s it, the scene is finished. Now we can render it properly.

The easy way to make any object point at
any other object is to select the first object

and then pick this menu option.

As you type into a Search text box,
CINEMA 4D will save you time by trying to

complete the name for you.
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RENDERING
At the moment, all of the fancy rendering functions are turned off. There’s no
shadows, no antialiasing and the picture is being rendered in a fast, lower quality
mode known as “scanline” rendering. We’ll adjust the render settings in a
moment, but before that let’s do a quick render to see what we’ve got.

1 Press the Render to External Window button.

If you study the output closely you’ll notice that most of the curves and diagonals
are a bit jagged. And there are a few things about the picture that don’t seem
quite right: the lino isn’t shiny, there aren’t any shadows, the spherical crystal
ball isn’t refracting the light passing through it...

We can fix all this and more in the Render preferences dialog.

2 Select Render from the File>Preferences menu.

3 Set Render Mode to Raytracer (if it isn’t already).

This section will take about
5 minutes to complete
(not inc. rendering time).

Before you render, always check that the
Render preferences are set appropriately.
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Raytracing is the highest quality rendering mode. CINEMA 4D automatically
used a lower quality while we were developing the scene (because it renders
much more quickly) but now we are going to force high quality.

4 Set Antialiasing to 1.5 Always.

5 Set Oversampling to 3x3.

Antialiasing will get rid of those jagged diagonals and curves. We’ve set it so
that anything CINEMA␣ 4D decides needs antialiasing will get antialiased. In
particular, antialiasing will cause tiny floor tiles in the distance to blur together,
which is how they would appear in reality.

The higher the level of oversampling, the more of the surrounding pixels are
taken into account when CINEMA␣ 4D is deciding whether to antialias a pixel
or not. A setting of 2x2 or 3x3 is normally sufficient. Keep in mind that each
level of oversampling will cause the render to take twice as long as the previous
level.

6 Set Transparency to With Refraction.

Setting this option will ensure that light is refracted (bent) correctly when it
passes through transparent objects. This will dramatically improve the
appearance of our crystal ball.

7 Set Reflection to All Objects.

The default setting (Floor&Sky Only) means that only the floor and sky objects
will be reflected in any material that has reflections switched on. That’s why
our lino wasn’t shiny—all it has been reflecting is the sky. Now it will reflect the
text and the crystal ball and will make a massive difference to our picture.

8 Set Shadow to Soft&Hard.

No shadows were being cast in our earlier renders. Setting this option will give
everything a better appearance of depth.

9 Go to the Output page.

10 Set Resolution to 800 x 600.

The General render preferences are where
you decide the quality of the output.
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11 Switch to the Save page and set Colours to 24 Bit (16 Million).

12 Press the Path button and then select a folder and give your picture a
filename.

Giving your picture an output path and filename will cause it to be saved to
disk automatically after it has rendered. The picture will save in whatever file
format was set in the Save page of the Render preferences dialog. If you don’t
provide a path and filename, when the picture has rendered you can save it by
selecting Save Picture As from the File menu of the Render window.

All done
We hope you have enjoyed your first tour of CINEMA␣ 4D . We covered a lot of
ground creating our simple scene and you now know enough to be able to
follow the animation tutorials with confidence. And that’s when the real fun
starts...

The render preferences Save page is where
you decide the output format of the frame or

frames to be rendered.
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ANIMATION
Having used many 3D features to create a static scene, now we are going to
use many of the 4D features to bring that scene to life.

As with the scene tutorial, the aim here is not to show you every single feature
of CINEMA␣ 4D , but rather to introduce you gently to the basic animation
features so that you have a solid foundation on which to build.

This is the plan.

First we are going to learn about a simple animation technique called “key
frame animation” by making the text fly off and come back again, while at the
same time spinning through 360 degrees.

Second we’ll learn about a slightly more advanced technique called “time line
animation” by making the individual letters of the text rotate and tumble while
the whole text is flying and spinning.

Third we’ll learn about animation paths, the technique we must use if we want
to have total control over how each and every object in the scene moves or
changes over time. In this final part of the animation tutorial we will introduce
a glowing light into the scene that changes colour while floating around the
scene, and then we’ll “pick up” the camera and zoom right in on the crystal
ball.

Key frame animation
Key frame animation is the simplest form of animation within CINEMA␣ 4D and
it involves just three steps. First we take a snapshot of an object at one point in
time, then we take a snapshot of the same object at another point in time. If
between the two snapshots (known as key frames) the object has moved,
changed colour, grown, shrunk or has been altered in any way, CINEMA␣ 4D
will perform the third step in the process—it will create an animation that
transforms the object from the first key frame to the last key frame.

Using the scene created in the previous section, for our key frame animation
we are going to animate the text so that it moves towards the camera while
rotating through 360 degrees.

This section will take about
20 minutes to complete
(not inc. rendering time).
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1 Open the Crystal Ball scene and select the 4T view.

2 Open the Object Manager if it isn’t already open and click on the name of
the extruded text object (that we named “Mystic Peg” and you might have
named something else), and then ensure that the Model Tool button is
selected.

Now we must set the key frames that CINEMA␣ 4D will use to build the
animation. We do this in the Time Manager.

3 Open the Time Manager from the Window menu.

This window contains a slider and some VCR style buttons. The slider represents
a point in time in an animation, represented as a time in seconds or as a frame
number. Note that a frame that is at 2 seconds on the slider would also be the
30th frame of an animation that has a frame rate of 15 frames per second (fps).

The buttons are used just like a VCR—they enable us to navigate through the
animation and its key frames.

The Time Manager is where you record the
key frames of your animation.
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3 Set the slider to frame zero if it is not already there. Ensure that the Position
and Direction options are selected.

4 Press the Record button.

This has recorded a key frame for the text at time zero. The key frame will
include data for the object’s position in the 3D world as well as the direction in
which the object is pointing.

5 Ensure that the FPS field is set to 15 frames per second, then drag the slider
to the right until it reads 40.

6 Open the Coordinates Manager. Ensure that World Coordinates is switched
off, then add +360 to whatever value is currently in the H field under
Direction.

CINEMA␣ 4D allows us to enter formulae into value boxes. So entering +360
next to the H value will cause 360 degrees to be added to the current heading
of the selected object.

7 Select Apply (or press Return).

The 360 now gets added to whatever value was in the H box.

8 In the Time Manager, press the Record button.

It appears as though nothing has happened. Ah, but it has. Drag the Time
Manager slider between 0 and 40. See?

Getting CINEMA␣ 4D to rotate our text through 360 degrees is that easy . But
you’ve probably already spotted the problem. As the text rotates, it splats right
through the plinth. We need to move the text away from the plinth.

9 In the Time Manager, drag the slider to the 25 position.

10 Using the mouse, drag the text up and away from the plinth until the Z
Position value in the Coordinates Manager is at about -500. You will probably
find that it is easiest to perform this action in the side view (bottom left).

We move the slider to frame 40 ready to
record that frame as a key frame after we

have made the changes.

Now we must move the text because it is
passing straight through the plinth.

The animation needs to start somewhere, so
we record frame zero as our first key frame.

CINEMA 4D makes life easy by allowing us to
enter sums into value boxes.
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As we move the text, in the 3D view we can see that the text grows larger as it
approaches the camera and shrinks as it moves away from the camera.

11 Once the text is no longer cutting into any part of the plinth or crystal ball,
press the Record button in the Time Manager.

Pressing the Record button has taken a snapshot of the current frame of the
scene (a key frame) just as we have set it up. CINEMA␣ 4D will work out what
has to be moved or changed from the previous key frame to get the scene to
look like this. If we don’t press the Record button, the snapshot will not be
taken. Always ensure that the Time Manager is the active window before pressing
the Record button; if in doubt, press Record twice.

OK, if we now review the animation (by pressing the Play button in the Time
Manager) we can see that the text still collides with the plinth at around frame
6 or 7. To fix this we will have to go to the frame just before the text collides
with the plinth, move the text away from the plinth, then add that frame as
another key frame.

12 In the Time Manager, move the slider to frame 5.

The text is still colliding with the plinth at
about frame 6 or 7, so we must go to an

earlier frame and move the text further away.
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13 Using the mouse, move the text up and away from the plinth. When the
text is in a suitable position, press the Record button in the Time Manager.

We have almost finished our first animation. To complete it we have to render
it as a movie. On the PC this will be as an AVI file, on the Mac it will be as a
QuickTime Movie file.

14 Select Render from the File>Preferences menu and set the General settings
to the same as those used in the scene tutorial.

15 Select the Output page.

16 Set Resolution to 320x240.

17 Set Frames to Manual and change the field on the far right to 40.

18 Go to the Save page and set Format to AVI Medium (Windows) or Movie
Normal (Mac).

19 Set Colours to 24 Bit (16 Million).
When rendering animations, always check

that the Frames setting is set correctly.

For a much quicker (but lower quality)
render, set Antialiasing to None.
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20 Press the Path button, select a folder and filename for the movie file, then
press OK.

21 Press the Render in External Window button.

A new window will open in which our frames will be rendered one by one, and
our complete animation will be saved to the file named in the Render preferences
dialog.

To play the animation, double-click on the finished movie file and your default
movie viewer will play it for you. (On the PC this will normally be Media Player,
on the Mac it is usually Movie Player.)

In the next section we are going to use the Time Line window to animate the
individual letters of the text.
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Time line animation
Key frame animation is ideal for producing an animation that uses only a few
simple transformations. For more complex and professional effects we need to
use the time line—a visual representation of when an action starts and stops.

There are three terms we must become familiar with before using the Time
Line window in anger, these are tracks, sequences and key frames.

1 Open the Crystal Ball animation.

2 Select Time Line from the Window menu.

In the Time Line window you will notice that there are three entries labelled
Position, Scale and Direction. These are tracks that CINEMA 4D created
automatically for what we animated in the previous tutorial. The lines running
off to the right of the track names are called sequences. Along the sequences
there are some little markers. These represent the key frames (a term often
shortened to just “keys”) that again CINEMA 4D created automatically for the
previous animation.

If we double-click on a key or a sequence, a settings window for that key or
sequence opens. Double-clicking on a position or scale key opens a window
showing the X, Y and Z coordinates or scaling factors of the object at that key
frame, double-clicking a direction key opens a similar window but this time
showing the heading, pitch and bank (HPB) of the object at that key frame. A
double-click on a sequence body opens a window that enables us to set the
start and end time of that sequence.

Notice that the sequence has a “tail” that extends beyond frame 40, the last
frame of our previous animation. This is for no other reason than because the
default animation length happens to be 150. If the tail of a sequence bothers or

This section will take about
15 minutes to complete
(not inc. rendering time).

The Time Line provides a record of every
action performed in an animation, and allows

us to edit those actions.
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confuses you, simply select that sequence (click on it so that it turns red) and
select Adjust from the Function menu. This will shorten the sequence so that it
ends at the last key frame on that sequence.

OK, we are now ready to start animating the individual letters.

3 In the Time Line window, click on the little symbol to the left of the name
of our text object.

This symbol tells us that the object is actually a group of objects. Clicking the
symbol opens a list of all the sub-objects for an object. (The same system is
used in the Object Manager.) The main object is known as the parent object,
the sub-objects are known as the children of that parent object.

4 Click on the first sub-object of our text (which will be M if, like us, you
used “MYSTIC PEG” as your text).

It will turn red and all other object names in the list will be displayed in black.
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5 Go to the Function menu and select the New Track>Geometry>Direction
command.

6 Ensure the newly generated Direction entry next to the “M” is activated
(red) and select Function>New Sequence. In the Sequence Edit dialog that
appears, enter 0 into the From field and 40 into the To field, then press OK.

We have created a new direction sequence, starting at frame 0 and ending at
frame 40. Now we need to add some key frames to the sequence.

7 Hold down the Ctrl key and click right at the start of the direction sequence
we have just created. A Values and Tangents window opens that enables us
to add a key frame for the direction. Simply press OK.

8 Hold down the Ctrl key and click right at the end of the new direction
sequence. The Values and Tangents window appears again, this time enter
360 into the H (heading) field under Value.

The two key frames we have just set will cause the letter to spin 360 degrees
about its Y axis. This action will be completely independent of the parent object’s
sequences.

9 Go through steps 4 to 8 again to add a new direction sequence to the next
sub-object (Y in our example), add a new start key, and an end key that has
360 entered into the P (pitch) field under Value.

10 Go through steps 4 to 8 again to add a new direction sequence to the next
sub-object (S in our example), add a new start key, and an end key that has
360 entered into the B (bank) field under Value.

To animate a letter we have to first select it in
the Time Line window and then start a new

sequence for the animation to run along.
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Hmm. All this adding of new keys is getting rather tedious. There must be an
easier way. Indeed there is. CINEMA 4D allows us to drag-and-drop copies of
sequences.

11 Hold down the Ctrl key and drag the first sequence we created (for M) until
it is over the next blank sub-object (the T), then let go of the mouse button
to drop a copy of the sequence there.

If the left edge of the copy isn’t lined up with the sequences above it, simply
drag the sequence to the left until it lines up. If you click on and drag the
Direction track label (rather than the sequence line itself), then the alignment
of the original sequence will be duplicated and you won’t have to fiddle around
with the copy after dropping it.

Because we were holding down the Ctrl key, we have dragged a copy of the
sequence and key frame data. If we hadn’t been holding down the Ctrl key
then we would have moved the sequence rather than copied it.

12 Using the same drag-and-drop technique (holding down the Ctrl key,
remember), take the second sequence we created (for Y) and drag it on to
the next blank sub-object track (I in our example), aligning after dropping
if required.

13 Using the same drag-and-drop technique, add direction sequences to all
the remaining sub-objects.

OK, let’s have a quick look at what we have done.

14 Click in the Scene Editor and select Time Manager from the Window menu,
then press the Play button to view the animation in the Scene Editor.

We need to add direction sequences for
every letter of the text.
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The text is now taking off, as it was before, but now the individual letters are
spinning as well. Looks good to us, let’s raytrace it!

15 Using the same settings as we used for the previous animation, render this
new animation (but give it a new filename if you want to keep a copy of
the old animation).

So far we’ve looked at two animation techniques, and both ask CINEMA␣ 4D
to work out for itself how to move objects from A to B. This is fine for simple
work, but there will come a time when we know exactly how we want an
object to move from one point to another. To do this we need to lay down
paths for objects to follow. And that’s just what we’re going to do next.
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Animation paths
If we are building a complex animation that has lots of objects moving at the
same time, we are going to have a problem remembering where to set key
frames. To help with this, CINEMA␣ 4D allows us to define a path which we can
tell an object to follow. The technical term for this path is a “spline path”.

A spline path is nothing more than a line defined by a series of dots—imagine
a 3D join-the-dots puzzle. CINEMA␣ 4D includes a selection of predefined
splines, such as circles and squares, but when you become experienced you
will be able to draw any shaped spline path you like. To start with, let’s animate
an object along a predefined spline path.

1 Open the Crystal Ball scene from the last section.

2 Select Splines>Helix from the Objects menu.

3 In the Helix settings window, enter *2 next to the value in the Extrusion
field and *2 next to the value in the Rotation field, then press OK.

CINEMA␣ 4D allows us to enter formulae into value boxes. So entering *2 next
to the Extrusion and Rotation values will cause the default values of 200 and
360 to be doubled to 400 and 720.

4 Add a new light source to the scene (Objects>Scene Object>Light) and
rename it to Ball of Light.

This section will take about
10 minutes to complete
(not inc. rendering time).

Our first step in animating an object will
normally be to create a spline path for the

object to travel along.
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5 In the Light settings dialog for the Ball of Light, adjust the colour sliders so
that R is 100, G is zero, B is zero and S is 100.

6 Select the Visible Light page and set the Density field to XYZ Decreasing.
Set the X, Y and Z Radius settings all to 100, then press OK.

7 Open the Time Line window, ensure Ball of Light is the selected object,
and select New Track>Geometry>Spline from the Function menu. Create
a spline sequence for the Ball of Light that starts at frame 41 and ends at
frame 110 (Function>New Sequence).

8 Add a new key on the spline sequence (click with Ctrl held down) at frame
41. A box will appear asking for the name of a spline.

9 Start typing “helix” and before you even get to typing the “e” you will see
that the word “Helix” appears below the entry field. This is CINEMA 4D
completing the name for us. Press OK.

If we now return to the Scene Editor and review the animation by moving the
Time Manger’s slider, we will see the ball of light wind around the crystal ball as
it follows the path of the helix.

If we want to move an object along a path,
first we must create a spline sequence for

that object.
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10 Open the Render Settings dialog and using the same settings as we used
for the previous animation (ensure that the Frames option is set to All
Frames), render our new animation. (Give it a new filename if you want to
keep a copy of the old animation).

Recall that we have added 70 frames to the animation so it is going to take
about three times as long to render as either of our previous animations.

For our final two tutorials we are going to use some more advanced features to
add spit and polish to our animation. First we are going to fade the ball of light
into the scene so that it doesn’t just appear out of the blue, then we are going
to zoom the camera into the crystal ball and fade the whole scene out to white.

Animating lights
If you’ve played the animation rendered at the end of the previous section you
will have noticed that the red ball of light suddenly appears at the base of the
plinth and then starts moving up the spline path. This is not a particularly elegant
way of introducing the ball of light to the scene. What this section will deal with

This section will take about
2 minutes to complete
(not inc. rendering time).
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is animating the ball of light so that it fades into the scene, then changes colour
as it travels along the spline path.

1 Open the Time Line window, ensure that Ball of Light is the selected object,
and select New Track>Parameter>Light from the Function menu. Create a
parameter sequence between frames 41 and 110 for the Ball of Light
(Function>New Sequence).

2 Hold down Ctrl and click the left-hand end of the new parameter sequence
(labelled Light in the list) to add a key frame there. The Light dialog will
open. Leave the RGB values alone but set the strength of the colour (S) to
zero and set the Visible Light Brightness on the visible light page to 0%.
Press OK.

What we’ve done here is stop the light emitting any rays. In effect, we’ve turned
off the light. Now we’ve got to set a key frame where the light is full on.

We are going to change the parameter
settings (colour and strength) for the ball of

light, so we must first create a light
parameter sequence for it.
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3 Hold down Ctrl and click the Light sequence at around the frame 70 mark.
Leave the RGB values alone, ensure the strength of the colour is set to 100
and Visual Light Brightness on the visible light page is set to 100%. Press
OK.

Hmm. Have we set the key frame at the correct point? Sure, it looks like frame
70-ish, but we want it to be exactly frame 70.



77STARTING SIMPLY

4 Click on the key frame we’ve just created and select Edit Time from the
Function menu. The frame number of this key frame is in the entry field. If
it isn’t 70, make it 70 and press OK.

CINEMA␣ 4D will automatically fade in the ball of light from nothing to full
brightness over 30 frames (two seconds). Now we want it to change colour.

5 Add another key at the end of the Light sequence, and this time set R to
100, G to 100, B to 0, S to 100 and Visible Light Brightness to 100%.
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If we now play the animation from the Time Manager, the Scene Editor will
show the light change in colour as it goes from black (off) to red (frame 70) and
then to yellow (frame 110).

Don’t render the scene again at this point because we have just two little finishing
touches to put to it.

Animating textures
For the final scene of our animation we are going to make the camera move
from its current static position towards the crystal ball, and when it gets to the
point at which the crystal ball fills the camera view we are going to fade the
crystal ball to white (which in effect will fade the whole scene to white). Let’s
do the fade first.

1 Open the Material Manager, add a new material, rename it to White.

2 Double-click on the new White material to edit it.

3 Switch off the Colour option (no tick in the box).

4 Ensure that all other options are switched off.

5 Go to the Luminance page and switch on the Luminance option. Set the R,
G, B and S values to 100.

So what have we been doing? The material we have created has a brilliant,
pure white luminance, but it has no colour, no transparency and is not reflective.
We are going to feed this material into the Time Line so that CINEMA 4D can

We are creating a new White material so that
we can “animate” the Crystal material
gradually from one material to another.

This section will take about
2 minutes to complete
(not inc. rendering time).
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smoothly change the texture of the crystal ball from its current glasslike
appearance to this brilliant white.

6 Go to the Time Line window, ensure that Sphere is the selected object and
select New Track>Optical>Texture from the Function menu. Create a
texture sequence for the sphere (the crystal ball) that starts at frame 170
and ends at frame 200 using New Sequence from the Function menu.

7 Add a key at the start of the texture sequence (ctrl-click) and leave this set
to Crystal.

8 Add a key at the end of the sequence and set the texture to White.

Animating a camera
1 Open the Time manager if it isn’t already open and move the slider to

frame 110.

Since we are planning to move the camera, we need to add a camera object to
the scene so that we can set position sequences.

2 Go to the Scene Editor and select Objects>Scene Object>Camera. Accept
the present default values and press OK.

The new camera object will be placed in the same location as the current
Scene Editor camera.

3 In the Action toolbar, select the bottom right button—Attach Virtual Camera
To Object.

We want to gradually change a texture, so we
first need to create a Texture track and then a

sequence.

This section will take about
6 minutes to complete
(not inc. rendering time).

The Attach Virtual Camera to Object button.
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This button attaches the Scene Editor camera to the currently selected object.
Since the new camera object is the currently active object, the Scene Editor
view will switch to the view from the new camera object.

4 Press the Record button in the Time Manager and then move the slider in
the Time Manager to frame 170.

5 Ensure that the Model Tool button is selected and then lock the X axis
(leaving Z and Y unlocked).

6 In the Scene Editor, drag the camera object so that it almost touches the
crystal ball. (Ensure that it is the green-coloured camera you are moving,
not the red-coloured spline path for the camera.)

7 Press the Record button in the Time Manager.

Our animation is now complete. Well, OK, we haven’t rendered it yet, but
that’s all there is left to do.
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The final render
Now then. We’ve got 201 frames here with refractions and reflections all over
the place. Even at 320 by 240 pixels (VHS NTSC size) it is going to take quite a
while to raytrace. Exactly how long will depend on the speed of your computer.

With antialiasing and 3x3 oversampling, on the fastest professional Macintosh
it’ll take maybe two hours. On a fast home PC we’re looking at about nine
hours. On the slowest Power Mac it’ll take about two days.

If you are busting to view the animation as quickly as possible, then render it
with the settings we used before, but switch off antialiasing. The animation
won’t look quite as nice, the floor tiles in particular will have very jagged edges,
but the animation will render much more quickly—about four hours on the
slowest Power Mac; about one hour on a fast home PC; about 15 minutes on
the fastest professional Macintosh.

Also keep in mind that there is nothing to stop you rendering a high quality
version of the animation in lots of small stages, perhaps 10 or 20 frames at a
time, then using a suitable program to join the bits of the animation together.

Of course, we’re lucky, we bought CINEMA␣ 4D . Had we bought some other
modeller/raytracer then we might have had to wait a week, two weeks, a month
or more for this animation to render on our home PC or Power Mac.
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DAVE THE DONKEY
(Only XL version)
In the previous chapters of this book you've learned a lot about CINEMA 4D
basics (such as modelling, animation and rendering); techniques which can be
used with both Editions of CINEMA 4D (SE and XL). The following tutorial is
only for use with the XL-Edition of CINEMA 4D since it features many high-end
functions, which are not implemented in SE.

So, now you have a good idea of how to use the most important tools and
functions within CINEMA 4D, let's progress to some of the more complex and
powerful features of CINEMA 4D XL.

In this tutorial we are going to create, completely from scratch, an animated
toy donkey. We’ll be using several modelling techniques, including NURBS
and Boolean operations. Our donkey will have several animated parts. For the
neck and legs we’ll use inverse kinematics (IK) to make animating these parts a
piece of cake. We’ll be using IK for the tail as well, and we’ll also be placing
bones in the tail so that it can swish about. To animate the donkey’s eyes we’ll
use free form deformation (FFD) cages.

The donkey, whose name is Dave, will begin life standing on a base. However,
the base will be on fire, thanks to a 2D shader (procedural texture). (If you are
using the XL edition of CINEMA 4D, we’ll show you how to use the particle
system to make that fire smoke.) Dave will lower his head and, seeing that the
base is on fire, his eyes will pop out. Not surprisingly, at this point Dave legs it.

The floor
Let’s begin the scene by putting in a floor and a sky so that we have an immediate
sense of space and perspective in the scene.

1 Start a new scene. If you already have a scene loaded into CINEMA 4D,
save the scene if necessary, then select File>New.

2 In the Editor window, select Objects>Scene Object>Floor. Leave the name
as Floor and click OK.

This creates a floor which will disappear into the horizon. Its dimensions are
effectively infinite. Now we’ll add a material to it. Let’s use a 2D shader.

Depending on your modelling
experience, this tutorial will take
anything from about one hour to
a few hours to complete.
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3 Click in the Material Manager window to make it active, then select
File>New Material.

4 Double-click on the thumbnail of the new material. On the Colour page,
click the File button. Use the file selector to locate and open the 2D shader
file named “Marble.shc” (in the Tex/2D-Shader folder). Set Colour R to 60,
G to 40 and B to 40. Leave both Colour S and Texture S at 100%. Click on
OK.

This should give you a pinkish marble texture. We’re not going to add reflections
or other material properties because for this job we want the focus to be on the
action—we certainly do not want to add to the rendering time just for the sake
of it, no matter how fast CINEMA 4D is at rendering! Before we make the sky,
let’s rename this texture and apply it to Floor.

5 In the Material Manager window, select Function>Rename and change
the material name to PinkMarble. Since the Floor is already selected in the
Object Manager, let’s apply the material with Function>Apply. The Texture
dialog will open—the default settings are fine, so just click on OK.

The sky
1 In the Editor window, select Objects>Scene Object>Sky. Leave the name

as Sky and click OK.

2 In the Material Manager, select File>New Material. Change the name of
the material (Function>Rename) to Clouds.

3 Double-click on the thumbnail for Clouds. On the Colour page, click the
File button. Use the file selector to locate and open the 2D shader file
named “Cloud.shc”. Set Colour R to 60, G to 40, B to 40. Set Colour S to
0% and leave Texture S at 100%. Click on OK.

4 Drag the Clouds material on to the Sky object in the Object Manager.
Again, the Texture settings are fine, so simply OK that dialog.

The base
Dave needs something to stand on, so we’ll begin with the base. To build the
base we are going to extrude a circular spline and cap both ends of the resulting
cylinder, rounding the top cap. The first job is to create a spline.
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1 In the Editor window, select Objects>Splines>Circle Elements>Circle. Set
the radius to 100, then click OK.

2 Ensure that the circle spline is selected in the Object Manager, then back in
the Editor window select Objects>Spline Object>Extrude Object. In the
Extrude Object dialog that opens, change the name of the object to Base.
Leave Steps set to 1 but change Z to 100; this will make the base 100 units
tall.

3 Still in the Extrude Object dialog, go to the Cover Surfaces page. If you
leave all the options empty, this extrusion will produce a tube 200 units in
diameter with no caps (no top and bottom). We want caps, and we want
the top one to be rounded. To cap the bottom of the base, select the Start
Close option. To cap the top, select the Finish Close option. Select Round
for Finish, which will bevel the edge between the top and the side. Change
the Steps for Finish to 5 and make the Radius for Finish 10. Leave Hull
Inwards selected, which will bevel in toward the top (Hull Outwards would
curve out from the side to the top). Click OK and our extruded object will
appear in the Editor window.

Um. It’s on its side. No problem. We can use the Coordinates Manager to turn
it around.

4 Ensure that Base is selected in the Object Manager and that the Model tool
is selected (in the Tools palette). In the Coordinates Manager, set P to 90.
Under Position, set X to 0, Y to 55 (not 50, because of the rounding) and Z
to 0. Click the Apply button. The Base should now be standing upright on
the floor.

In the Object Manager, you should see our original spline object (Circle) and
the extruded object, which we named Base. The Base object name has a small
icon immediately to the left of it. If you click on this icon it will open the
hierarchy of the object, revealing the sub-objects that comprise the Base object.

When CINEMA 4D extrudes a spline it keeps the covers, bevels and extrude
objects separate. This makes it easy to apply different textures to these parts.
For our Base, we have sub-objects named Cover Surface 1 (Caps for Windows),
Rounding and Cover␣ Surface 2 (a sub -object of Rounding). If you click on each
name you will see in the Editor window which part is which.

4 … Before using the Coordinates Manager,
ensure that the Move tool is selected and

that Base is selected in the Object Manager.
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What we are going to do is apply a shiny green material to the base, with a gold
ring around the edge. Our Rounding is what we want to be gold, so all we have
to do is make the materials and assign them.

5 If it isn’t already open, open the Material Manager and choose the
File>New Material command to create a new material. Use
Function>Rename to change the name to BaseGreen.

6 In the Material Manager, double-click on the BaseGreen material thumbnail
to open the Material Editor. Use the Colour sliders to create a suitable
green (r25g55b0 for example). Let’s give it a little sheen by turning on the
Highlight (select the Highlight property). The default highlight is a bit strong
for the effect we’re after, so go to the Highlight page and change Width to
20% and Height to 80% (or whatever makes you happy). Click OK to finish
editing this material.

Next we’ll create a gold material for the base trim.

7 Still in the Material Manager, create a new material, rename it BaseGold
and double-click on it to edit it. Set the Colour sliders to r100g100b15 and
leave the strength of the colour at 100%.

8 To give the gold a highlight, select the Highlight property then go to the
Highlight page. Set Mode to Metal, Width to 75% and Height to 100%.

9 We’ve finished editing this material, so click OK.

Let’s quickly apply these textures and get back to the modelling.

10 Holding down the Shift key (to circumvent the Texture dialog), drag the
BaseGreen material on to Base in the Object Manager.

Note that our entire base is now green. CINEMA 4D will apply a material to all
sub-objects that have not had materials of their own applied to them.

11 Shift-drag the BaseGold material to the Rounding sub-object in the Object
Manager.

Um. Now our green base has a golden top. Not quite what we are after.

9 … After finishing editing the Base
materials, your Material Manager should look

something like this.
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12 Shift-drag the BaseGreen material on to Cover Surface 2 (a sub-object of
Rounding) and there we have it, a green base with a gold trim.

OK, onwards and upwards (literally) to something more challenging—legs.

The legs
It’s time to start modelling Dave the Donkey. Legs are always a good place to
start, so let’s build and texture one leg, then duplicate it three times to create
the others. We’ll start with a hoof, for which a cylinder will be fine.

1 In the Editor window, select Objects>3D-Object>Cylinder. Name it
HofFrtRgt (short for Hoof Front Right), change Radius to 15, Height to 30
and keep Cover Ends selected (this gives us a top and bottom). Click OK to
create the object.

Now let’s put the hoof on top of the base. Our Base is 100 units tall, plus 10
units for the rounding. The centre of our hoof is 15 units in the Y direction. If
we add all three distances, we get 125 units.

2 If it’s not already open, open the Coordinates Manager. Enter 125 in the Y
Position box and click Apply. If your hoof doesn’t sit exactly on the base,
go back and check the coordinates of the Base.

We do not intend to texture the ends differently from the sides, so to simplify
things we will connect all the parts of the HofFrtRgt object into a single object
with no sub-objects.

3 Select HofFrtRgt in the Object Manager, then in the Editor window choose
the Tools>Structure>Connect command. This creates a new object named
HofFrtRgt.1.

4 We no longer need HofFrtRgt, so select it in the Object Manager and hit
the Delete key.

5 Double-click on the HofFrtRgt.1 object name and change its name to
HofFrtRgt.

Time for the lower leg to make an appearance. Here we’d like a cylinder with
a bevel on the top and bottom, so let’s extrude a circle again.

5 … If after using the Coordinates Manager
to move the hoof it doesn’t sit exactly on top

of the base, check the size and position of
the Base and adjust as necessary.
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6 Create a circular spline (Objects>Splines>Circle Elements>Circle) with a
radius of 10 units. Rotate it by 90 degrees (P=90 in the Coordinates
Manager). Extrude it 50 units along the Z axis. Close and Round the Start
and Finish with 5 Steps and a Radius of 7. Change the name of the object
to LowLegFrtRgt (short for Lower Leg Front Right), then click OK. (If we’ve
gone a bit too quickly for you here, please go back and study the step-by-
step description for creating the Base object.)

We’ll not worry about position just yet, let’s press on and create the upper leg.

7 Select LowLegFrtRgt in the Object Manager and make a duplicate of it (Ctrl-
drag the object name). Since the duplicate object (LowLegFrtRgt.1) occupies
the same space as the original, everything looks the same in the Editor
window. Before things get confusing, let’s change the name of the duplicate
object to UppLegFrtRgt (double-click on the name in the Object Manager
to open the Rename dialog).

Often during the modelling process you will find it useful to zoom in on areas
in order to concentrate on the part of the model on which you’re currently
working. To zoom in, select the Zoom tool (in the Action palette) and drag over
the area you want to magnify. To zoom out, Ctrl-drag a small box. From time to
time, you may also want to change the view by selecting one of the five view
tools in the View palette.

8 Select the Front View - XY tool (in the View palette) and zoom in or out as
required—we want to see the area above the base so that there is room to
position the front right leg.

Now we want to move the leg parts up the global Y axis to form a straight leg.

9 Click on LowLegFrtRgt in the Object Manager. Ensure that the Model tool is
selected (in the Tools palette) and that the Move tool is selected (in the
Action palette), then deselect the X and Z axes (in the Action palette) so
that only the Y axis is active.

10 Select the World Coordinate System tool (in the Action palette).

11 Move LowLegFrtRgt up the global Y axis, above the hoof, but maintain a
little overlap.

12 Now select UppLegFrtRgt in the Object Manager and move it up the global
Y axis, above LowLegFrtRgt, but again make sure there is some overlap.

8 … Always remember that you can zoom
into and out of any scene at will in order to

adjust positions by hand with great accuracy.

11 … When positioning the lower leg on top
of the hoof, ensure that the two overlap

slightly.

12 … When positioning the upper and lower
legs, again ensure there is a small overlap.
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13 OK, let’s put some materials on the leg. The hoof is black, with a little
highlight. The lower leg is tan (r70g50b30), with a little highlight. The upper
leg is red (r75b0g0) with a little highlight. The Colour S value is 100% for
each material. Create these materials, give them meaningful names, apply
the materials to the appropriate parts of the leg.

Don’t concern yourself if the highlights seems a little bright when you render in
the XY view, they’ll look much better when rendered in 3D.

Inverse kinematics for the leg
Towards the end of the animation, Dave is going to jump off the base, so we
are going to apply inverse kinematics (IK) to the leg. Inverse kinematics will
enable us to move the end object of a hierarchical chain, and have the rest of
the chain automatically change to accommodate this movement. So in our
case, we will move the hoof and expect the rest of the leg to come with it.

IK is accomplished by rotating objects about their axis system, the essential
point here being that the object axis system has to be moved to wherever we
want the “joint” to be. Let’s get these axes into the right positions.

1 Zoom in on the leg in the XY view.

We need to move the origin of LowLegFrtRgt’s object axes up to the centre of
the cross-section between the upper and lower leg. To move an object’s axes,
simply drag the mouse, ensuring that the appropriate object, the Object Axis
tool and the Move tool are selected. If you need to move the axes in only one
direction, it will help if you turn off the directions with which you are not
concerned.

2 Select LowLegFrtRgt in the Object Manager, select the Object Axis tool (in
the Tools palette) and ensure that the Move tool (in the Action palette) is
selected.

3 We want to move the axes up the global Y axis only, so turn off the X and Z
axes (in the Action palette). Select the World Coordinate System tool (in
the Action palette).

4 Select UppLegRgt in the Object Manager and move the origin of its object
axes up to near the top of the object

13 … After applying materials to the parts of
the leg, when rendered your base and leg

should look something like this.

3 … Remember, if you want to move an
object only in one direction, it’ll be easier for
you if you turn off the axes for the directions

you want to freeze.

4 … To move an object’s axes you must have
the Object Axis tool selected in the Tools
palette and the Move tool selected in the

Action palette.
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We don’t need to change the origin for the hoof, so we can leave that as it is,
but it will help to simplify IK later on if we now line up the coordinate systems
for the upper and lower leg with the global axes.

5 Ensure that the Object Axis tool is selected (in the Tools palette). In the
Object Manager, ensure that UppLegFrtRgt is still selected. In the
Coordinates Manager, change the P value to 0 and Apply.

That takes care of the upper leg. Now for the lower leg.

6 Select LowLegFrtRgt in the Object Manager. In the Coordinates Manager,
change the P value to 0 and Apply.

OK, now we can work on IK. An IK chain must be arranged hierarchically so
that the end of the chain is the deepest sub-object.

The leg hierarchy needs to be hoof inside lower leg inside upper leg so that
when we drag the hoof (the end of the chain), we’ll expect the upper and
lower leg to come with it.

We establish an object hierarchy by dropping children on to their parents.
We’ll do this now.

7 In the Object Manager, drag HofFrtRgt on to LowLegFrtRgt. Then drag
LowLegFrtRgt on to UppLegFrtRgt.

Although IK will come into play only once the legs are attached to the body
(the body will anchor the IK chain), it’s OK for us to apply the IK property to the
leg now.

6 Click on UppLegFrtRgt in the Object Manager and select the Function>New
Property>Inverse Kinematics command.

7 In the Inverse Kinematics dialog, select the H, P and B options.

8 Set the heading values H Maximum and H Minimum to 0; this will prevent
the leg from twisting.

9 Set pitch values P Maximum and P Minimum to 0; this will prevent the leg
from moving from side to side.

7 … After dragging HofFrtRgt on to
LowLegFrtRgt, and then LowLegFrtRgt on to
UppLegFrtRgt, if you open the hierarchy it

will look like this.



93GETTING SERIOUS

10 Set bank values B Minimum to -60 and B Maximum to 60; this will allow
the leg to move forwards and backwards by 60 degrees in each direction.

11 Set Damping to 50%; this will stiffen the joint a little.

12 Click OK to confirm the settings and close the Inverse Kinematics dialog.

Now for the lower leg.

13 Select LowLegFrtRgt in the Object Manager. Next, select the Function>New
Property>Inverse Kinematics command. In the Inverse Kinematics dialog,
select the H, P and B options. Set H Maximum and H Minimum to 0, P
Maximum and P Minimum to 0. Set B Minimum to 0 and B Maximum to
90 (prevents forward movement but allows backward movement by 90
degrees). Set Damping to 50%. Click OK.

And the hoof…

13 Select HofFrtRgt in the Object Manager. Select the Function>New
Property>Inverse Kinematics command. In the Inverse Kinematics dialog,
select the H, P and B options. Set all the H, P and B values to zero, then
click OK. These zero values will keep the hoof in line with the lower leg.
Although the hoof itself has no IK movement, it will be more natural to
move the hoof (rather than the lower leg) when animating the leg.

That’s all the IK work done for that leg! Now we can create the remaining three
legs using copy-and-paste.

14 Select UppLegFrtRgt in the Object Manager, copy it (Edit>Copy), and then
paste it (Edit>Paste) three times.

15 We’ll position the now, but before we get really confused let’s rename the
legs, and the parts (sub-objects) of each leg. For example, for the back left
leg, rename UppLegFrtRgt.1 to UppLegBckLft, LowLegFrtRgt (sub-object of
the newly renamed UppLegBckLft) to LowLegBckLft, and HofFrtRgt to
HofBckLft.

Now that we have renamed all of the legs, let’s arrange them in a suitable
fashion.

13 … For the lower leg we are saying that
the maximum and only IK movement it can

make is 90 degrees forwards, stiffened
somewhat by a 50% Damping value.

15 … After copying and renaming, the
hierarchies for all four legs should look like

this in the Object Manager.
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16 In the Object Manager, select the parent of each leg in turn (UppLegLftRgt,
for example), then, ensuring that the Model tool is selected, use the
Coordinates Manager to change the position of each leg.

17 For UppLegFrtRgt, change Position X to 60, Position Y to 260, and Position
Z to -25.

18 For UppLegFrtLft, change Position X to 60, Position Y to 260, and Position
Z to 25.

19 For UppLegBckRgt, change Position X to -60, Position Y to 260, and Position
Z to -25.

20 For UppLegBckLft, change Position X to -60, Position Y to 260, and Position
Z to 25.

At last Dave the Donkey is beginning to take shape!

The body
1 Create a cylinder (Objects>3D-Object>Cylinder), name it Body, make the

Radius 45, the Length 200 and deselect Cover Ends (here we don’t need to
cap the cylinder) and click OK.

2 Now rotate it by 90°—ensure that the Move tool (Action palette) is selected,
then enter 90 as the B value in the Coordinates Manager.

3 Still in the Coordinates Manager, enter 300 as the Y value.

4 Create a sphere (Objects>3D-Objects>Surface Sphere), name it Chest,
make its Radius 45 and click OK.

5 Position it on the front of the body by entering X=100 and Y=300 under
Position in the Coordinates Manager.

6 Create another sphere, this one named Rear. Keep the radius at 45 and
place it at the rear of the body (-100,300,0).

We need to flatten the chest somewhat. This is easily accomplished with a
Boolean operation. Boolean operations combine two objects in a specific way
to create a third object. There are several different types of Boolean operation—

17-20 … After positioning all four legs on
top of the base, your rendered scene should

look something like this.
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please see the reference manual for more details—and we will use the A Minus
B operation to trim the chest. We already have our A object (the chest), but we
need to create our B object.

7 Create a cube (Objects>3D-Objects>Cube) of Edge Length 100. No need
to rename the cube (we will be discarding it in a few seconds), so click on
OK to create it.

8 Use the Coordinates Manager to position the cube at 180,300,0 (the X
value here will determine how much we trim off the sphere).

9 In the Editor window, select the Tools>Boolean command to open the
Boolean Operation dialog. Change Mode to A Minus B. Object A should
be Chest, Object B should be Cube. Click OK once you’ve set these values.

When CINEMA 4D performs a Boolean operation it creates a new object, leaving
the source objects intact. The source objects are neatly hidden from view (using
display property icons), on stand-by in case you don’t like the end result of
your Boolean operation. Since we like our result, we can get rid of the source
objects.

10 In the Object Manager, delete the original Chest and Cube objects

The object created by the Boolean operation is named Chest—Cube (since it
has been made from these objects). Let’s simplify things by making the body
parts (legs not included) into one object. We need to use the Connect command
to connect Rear and Chest—Cube to Body.

11 Drag Rear and then Chest—Cube on to Body in the Object Manager.

12 With the Body object selected, in the Editor window select
Tools>Structure>Connect. A new object named Body.1 will be created.

13 Delete Chest—Cube, Body and Rear.

14 Rename Body.1 to Body.

We will use the body as an anchor for the inverse kinematics that we have
applied to the legs and, later, will apply to the neck. Since the IK angles have
been calculated with world coordinates in mind, we need to point the coordinate
system for the body in the same direction as the world coordinates.

8 … We can use a cube and a Boolean
operation to slice off part of the “chest”

sphere, thus flattening it.

9 … Always remember that in Search For
boxes you need only type the first few

characters of a name for CINEMA 4D to find
the object you are looking for.
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15 Ensure that Body is selected in the Object Manager and select the Object
Axis tool (Tools palette).

16 In the Coordinates Manager, change the B value to 0.

The HPB values should now all read zero. If we had not changed the body axis
system in this way, the IK values would need to be recalculated. OK, now we’re
really getting somewhere! Onwards and upwards. Next comes the neck.

The neck
1 Create a cylinder (Objects>3D-Objects>Cylinder), name it Neck, set Radius

to 17.5 and Height to 100. Select Cover Ends and then click OK.

2 With Neck selected in the Editor window, select the Tools>Structure>Connect
command. A new object named Neck.1 will be created.

3 Delete Neck.

4 Rename Neck.1 to Neck.

5 Select the Model tool (Tools palette) and, using the Coordinates Manager,
position Neck at 110,380,0.

We want Dave to move his neck up and down during the animation, so we’ll
apply IK to his neck. Since IK rotations occur about the origin of the object’s
local coordinate system, we need to move the axes to the base of the neck.

6 Ensure that Neck is selected in the Object Manager. Select the Object Axis
tool (in the Tools palette) and in the Coordinates Manager change Position
Y to 330.

Now we’ll apply the IK property.

7 In the Object Manager, click on Neck and then select the Function>New
Property >Inverse Kinematics command. In the Inverse Kinematics dialog,
select the H, P and B options. Set H Maximum and H Minimum to 0, P
Maximum and P Minimum to 0. Set B Minimum to -45 and B Maximum to
135 (so that the neck can move back a little and forwards a lot). Leave
Damping at 0%, which will give us a floppy neck. Click OK.

6 … With the Object Axis tool selected you
can use the Coordinates Manager to adjust

the position, size and direction of the
currently selected object’s axes.

5 … When you know the position and size of
other objects in your scene, very often it is

quicker and more accurate to position
related objects using the Coordinates

Manager rather than move them by hand in
the Editor window.

If Dave is becoming too tall for your current
editor views, don’t forget that you are free to
change these at will. Either reposition your
view using the Camera tool, or zoom in/out

with the Zoom tool.
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Again, as with the legs, the anchor for the neck will be the body, but we’ll come
back to that later when the hierarchy is correct.

The head
Now, let’s give Dave a head. To create this shape we are going to rotate (lathe)
a spline. To create a spline we first need to create an Empty Spline object.

1 In the Editor window, select Objects>Empty Spline. Change the name to
HeadSpline and select Hermite as the Type—this will create a spline of
Bezier control points. Since we want an open spline (not closed, like a
circle or polygon), leave Close Spline deselected. Leave the interpolation
values as they are and click OK. This will create in the Object Manager an
object named HeadSpline (which will be empty but still has its set of axes).

2 Using the Coordinates Manager, move HeadSpline to a location around
the top of the neck (110,450,0).

3 Zoom in on the area around the head.

4 Now let’s create the spline. With HeadSpline selected in the Object manager,
click on the Points tool (in the Tools palette). We will need five points for
this shape, and since CINEMA 4D rotates around the Y axis, we will have to
create our head vertically, then change it to the correct orientation. To
create a point, Ctrl-click at the position where you want the point to appear.
Create five points arranged similarly to those in the example to the left. To
move a point, click on it to select it, then drag the mouse.

Note that the hermite handles are not created automatically. A Hermite spline
is initially created without tangents (this is termed hard interpolation) because
usually you will want some of the points to be hard. So how do we get some
handles in order to adjust the tangents to produce the required curvature (this
is termed soft interpolation)?

5 Ensure that the Points tool is selected and that HeadSpline is selected in
the Object Manager and in the Editor window select the Window>Structure
Manager command.

The Structure Manager is extremely versatile and is used for low-level work on
splines and polygons. One of the things we can do from here is select points in
a Hermite spline and change the interpolation of those points from hard to soft

4 … For the head shape we need to create a
an open spline using five points arranged

roughly like this.

5 … Although a little daunting to beginners,
the Structure Manager is extremely versatile
for low-level work and is well worth taking

the time to get used to.
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(or vice-versa, of course). In our case we want handles for all of the spline
points—we want all of the points to be soft, in other words. First, we need to
select all of the points in the spline.

6 In the Structure Manager, select the Edit>Select All command.

7 Still in the Structure Manager, select the Splines>Soft Interpolation
command to make the selected points in our spline (all of them in our
case) soft. Now look at the spline in the Editor window; you should see a
curvy line with the tangent handles visible. (Please consult the Reference
Manual if you require more information on Hermite splines.)

8 Click on each point individually and drag the handles around until you get
something similar to the shape in the example to the right.

Don’t worry if you cannot exactly replicate our example, just get something
that is roughly similar.

9 Ensure that the beginning and end points of the spline are exactly on the Y
axis (X=0 in the Coordinates Manager). If they are short of the Y axis, when
the spline is rotated there will be a hole in the resulting object.

OK, now let’s make that object. This time we are going to use NURBS modelling
rather than plain spline-based modelling. NURBS modelling allows us to change
the generated object in realtime, while we edit the spline! So if we don’t like
the object, we can simply edit the points in the underlying spline until it’s
perfect.

10 With HeadSpline selected in the Object Manager, in the Editor window
select the Objects>NURBS>Lathe NURBS command.

11 Change the Name to Head, deselect Display Isobaths and click OK to create
the object.

Now then, we won’t yet be able to see the newly generated object because we
need to drag-and-drop HeadSpline on to Head in the Object Manager. But
first we need to place the Head origin in the same position as the HeadSpline
origin so that the Y axes line up (this is the axis of rotation).

12 With the Model tool (Tools palette) selected, use the Coordinates Manager
to change the Position values of Head to 110,450,0.

7-8 … After applying soft interpolation to all
of the points along the spline, the tangent

handles of those points will become visible,
enabling us to drag them about and change
the shape of the curve to our requirements,

as shown below.

9-13 … After lathing and positioning, the
head object should look a little like this.
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13 Now drop HeadSpline on to Head in the Object Manager to create our
NURBS object.

If we want to alter this NURBS object, all we have to do is change the points of
HeadSpline.

14 Select the Points tool.

15 Select HeadSpline in the Object Manager.

16 Select the Move tool.

17 Select the World Coordinate System tool.

18 Turn off the Y and Z axes (ensure that the X axis is on).

19 In the XY view, click on the left-most point of HeadSpline and drag it towards
the left side of the screen.

See how easy it is to change the object? No need to delete the object as with
spline objects, and you also get realtime feedback in the editor. Put that point
back where it was (or simply undo the operation).

20 Alter any or all of the points until the head looks something like the example
to the left.

Now to position the head.

21 With the Model tool (Tools palette), rotate the Head object (that’s Head,
not HeadSpline) by 90° (B=90 in the Coordinates Manager).

Since we didn’t define each point exactly (we could have, of course), your
Head may be different to ours, so you will have to position it yourself by hand.

22 Drag the Head over the Neck so that it looks like this in the XY view:

Now that we’re happy with the head, we can convert the Head NURBS object
into a regular polygon object.

Whoa! If NURBS are so great, why change it into a polygon? Because we’ve
finished the realtime modelling, that’s why. You don’t have to convert NURBS

14-19 … After making an object a NURBS
object, it is very easy to change the shape of
that object by selecting and dragging points.

20 … After reshaping your head it should
look something like this.

21-22 … And this is how your head should
look after rotating and positioning it.
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to polygons, but you will need to if you want to apply special effects. Do keep
in mind that, although you can convert a NURBS object into a polygon, you
can’t convert a polygon into NURBS object.

23 With Head selected in the Object Manager, in the Editor window select the
Tools>Structure>Convert To Polygons command. Enter 24 for Subdivisions,
then click OK. A new object named Head.1 will be created.

24 Now that Head is redundant, you can delete it.

25 Rename Head.1 to Head and delete its sub-object (HeadSpline).

Right, let’s stick a nose on this head.

26 Create a sphere (Objects>3D-Objects>Surface Sphere) of Radius 40 and
name it Nose.

27 Since the nose is going to be a part of the head, make it a sub-object of
Head by drag-and-dropping Nose on to Head in the Object Manager.

28 Select Nose in the Object Manager, and use the Coordinates Manager to
set its position to 0,0,0. This actually puts the nose partially inside the
head, but now we need only to drag it (in the X direction only) until we get
something similar to the illustration on the left.

29 In the Object Manager, drag-and-drop Head on to Neck to make the head
a child of the neck. As we have applied IK to the neck, this will ensure that
when the head moves, the neck bends appropriately. (At least it will when
we have anchored the neck to the body; we’ll do that later.)

The ears
To model the ears we’re going to use a terrific modelling tool: the Loft NURBS.
This tool takes a number of splines that form cross-sections of an object and
creates surfaces between those splines.

1 Create an Empty Spline (Hermite) and name it EarSpline. This will be easier
to work on away from the rest of the model, so use the Coordinates Manager
to move it to -300,0,0.

2 Zoom out from the scene, then zoom in on the new EarSpline in the XZ
view.

26-28 … Putting a nose on our head is a
simple matter of pushing an appropriately

sized sphere into its face.
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3 Select the Points tool and place three points as illustrated in the upper
example to the left.

Now we need to bring out the tangent handles.

4 Open the Structure Manager, select all the points and change them to soft
interpolation, just as we did for HeadSpline earlier.

5 Back in the Editor window, drag the tangent handles till you get a curve
similar to the one illustrated in the lower example to the left.

6 Ensuring that EarSpline is selected in the Object manager, select the
Tools>Duplicate command. Set Copies to 2, set the Y Move value to 200
and click OK; this will spread the copies along the Y axis and place them in
a new Object Group.

7 We want to add our original ear spline to this Object Group, but if you
open the group you’ll see that there is already an object in there named
EarSpline (as well as an EarSpline.1). To avoid confusion, rename EarSpline.1
to EarSpline.2 and EarSpline (in the Object Group) to EarSpline.1. Now
drag-and-drop the original EarSpline into this group.

We’re now going to fiddle with the points of the middle spline to create the
major contour of the ear. So without further ado, let’s make a NURBS object so
we can see the result as we refine the splines.

8 In the Editor window, select Objects>NURBS>Loft NURBS. Name the
object EarRgt, deselect Display Isobaths and click OK.

9 Select the Model tool (Tools palette) then use the Coordinates Manager to
change the position of EarRgt to -300,100,0.

10 Now, one by one, drag the three splines out of Object Group and drop
them in EarRgt. Ensure that the order of the splines in EarRgt is as illustrated
in the example to the right. Delete the now empty Object Group.

OK, now we can see the EarRgt object. We’re going to create the curve of the
ear simply by resizing the splines. The spline for the top of the ear (EarSpline.2)
will be smallest, EarSpline.1 can stay the same size, and the bottom of the ear

3-5 … To model an ear we first create a
spline with three points (above) and adjust

the curve to suit (below).

10 … After dropping the ear splines in the
EarRgt object, ensure that they are listed in

this order. The order of the splines is
critical—the surface is stretched over the
splines in the order they are listed in the
group; so, in our case, the surface joins
EarSpline.2 to EarSpline.1, then joins

EarSpline.1 to EarSpline.
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(EarSpline) should be between the sizes of the other two. Hey! This is NURBS
modelling how it should be—changing splines till the result looks right!

11 In the 3D view, zoom in on the ear.

12 Select the Model tool (Tools palette) and the Scale Active Element tool
(Action palette).

13 Ensure that all three axes are on (Action palette).

14 Resize first EarSpline.2 and then EarSpline until you have a wonderful ear
that looks something like the one illustrated in the example to the left.

15 Now we should adjust the axis position. We want the ear to rotate around
its base, so ensure EarRgt is selected in the Object Manager, select the
Object Axis tool (Tools palette) and in the Coordinates Manager set the Y
value to 0.

16 To ensure that the ear stays attached to the head we need to make it a sub-
object (child) of the head. In the Object Manager, drag-and-drop EarRgt on
to Head and, with EarRgt still selected, select the Model tool (Tools palette)
and use the Coordinates Manager to position EarRgt at 0,0,0.

17 Now, in the Editor window drag EarRgt along the global Y and X axes (turn
off the global Z axis) until it is sitting on top of the head.

Weird, huh? A one-eared donkey. But hey, if you like it… If not, we need
another ear.

18 Select EarRgt in the Object Manager and Ctrl-drag to make a copy of it.
Rename the copy EarLft.

19 Drag-and-drop EarLft on to Head in the Object Manager.

Now the Head has both ears and the nose as sub-objects. We’re almost done!

20 Use the Coordinates Manager to rotate EarLft by 20° (H=-20). Do the same
for EarRgt using 20 for its H value.

21 In the Editor window drag the ears apart.

15-17 … To position the ear we need to
rotate it and then drag it on to the head.

18-22 … You should end up with two ears
on top of the head, something like this.

11-14 … After lofting and scaling, our ear
should look something like this.
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22 Finally, in the Coordinates Manager adjust the pitch of each ear a little by
changing the P value to -15 for EarRgt and 15 for the EarLft.

The tail
Dave is almost a complete donkey. All he needs now is a tail. (Hey, keep it
clean!) Using IK once again, we’ll apply a bones hierarchy to the tail so that we
can very easily make it swish around.

We’ll form the tail using a Pipe Object. CINEMA 4D creates a Pipe Object by
extruding a circle along a spline path. We need to create that path, but
CINEMA␣ 4D will do the rest.

1 Create an Empty Spline (Hermite) and name it TailSpline. Working at the
rear of the Donkey, add three or four points to get something similar to the
upper example to the left. (Don’t forget to select the Points tool and use
the Structure Manager to make the spline soft.)

2 Ensure that TailSpline is selected in the Object Manager and, in the Editor
window, select the Objects>Spline Objects>Pipe Object command to open
the pipe object dialog.

3 Change the name to Tail, change Pipe Radius to 5.

4 Go to the Cover Surfaces page and Close the Start and Finish.

5 Click OK.

If there’s a gap between the tail and the body, feel free to move the tail closer.
Now for the most exciting part of this section—bones!

6 In the Editor window, select the Objects>Bone Object command. In the
dialog that opens, change the name to TailBone, set Length to 12, then
click OK. That’s the bone created, now we need to position it.

7 Ensure that TailBone is selected in the Object Manager and that the Move
tool (Action palette) is selected.

8 Select the World Coordinate System tool (Tools palette).

9 Ensure that the X and Y axes are on, but turn off the Z axis (Action palette).

6 … The Bone Object dialog is fairly complex
(please see the reference manual), so we’ll

keep things simple for the moment.

1 … Once again we begin modelling an
object by creating a spline. This one we are

going to “pipe” to create the object
illustrated below.
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10 Position the bone near the base of the tail. In the XY view, change your
viewing position to be a little nearer Dave’s rear end and position the bone
accurately, as illustrated in the example to the left. (You will need to change
its H value in the Coordinates Manager to 90, and P to about 24.)

Now we have to create a number of other bones. Notice that there is an orange
point on the end of the bone. If you ctrl-drag that point, you will create another
bone. The handy thing here is that the new bone will instantly become a child
of the one from which it was dragged—the hierarchy is set up for us, making it
a breeze to add IK later.

11 Turn on the Y and Z axes, turn off the X axis.

12 Select the Move and Object Coordinate System tools. Ctrl-click on the
orange point of TailBone and, while keeping the mouse button held down,
drag out a new bone. You can rotate it while you drag, making it easy to
position. Try to keep the end points of the bone along the centre of the tail.

13 Now create more bones to run the length of the tail, each time ctrl-dragging
a new bone from the last one you created. Don’t worry about the exact
number of bones, but aim for about 10 to 12. The more bones you create,
the smoother tail movement will be, but later on we’ll be opening the
hierarchy so don’t get too carried away. As ever, feel free to change the
view to aid your work.

Now we’re going to apply the anchor property to the parent (top) bone. We’ll
add IK properties to all the child bones. We can use the same IK settings for all
the child bones, so this won’t take long at all.

14 Select the parent bone in the Object Manager, then, still in the Object
Manager, select Function>New Property>Anchor.

15 Select the next bone in the bone hierarchy (the first child, in other words),
then select Function>New Property>Inverse Kinematics. In the dialog that
opens, select the H P and B options. Set all three minimum values to -20,
then set all three maximum values to 20. Click on OK to set these values
and close the dialog. An IK icon will appear in the Object Manager as a
property of the first child bone.

16 Now hold down the Ctrl key and drag-and-drop that IK icon on to the next
child in the bones hierarchy. Drop it exactly where you would expect it to

10 … Position the first bone right at the base
of the tail.

12 … Hold down the Ctrl key and ctrl-drag a
new bone from the little orange point at the

tip of the first bone.

13 … Continue ctrl-dragging bones until the
entire length of the tail is bony.
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appear—immediately below the IK icon we are copying, that is. (Note that
ctrl-drag-and-drop creates an exact copy of a property—one with the same
values, that is.)

17 Repeat this ctrl-drag-and-drop process until all the children have the IK
property.

18 To finish off the tail we need to make the bones children of Tail and then fix
the bones. By fixing the bones we tell CINEMA 4D where the bones should
be in the initial state. To make the bones children of Tail, all we have to do
is drag the parent bone on to Tail in the Object Manager.

19 Now to fix the bones. With the parent tail bone still selected, choose the
Function>Fix Bones command (Object Manager menu). You will be asked
if you want to include sub-objects. Since we need to fix all of the bones in
the hierarchy, click Yes.

You’re probably itching to see the bones in action. OK, let’s have a go, but save
the scene first so that we can return to the initial state once we’re convinced
that the bones work as expected.

20 In the Object Manager, open the bones hierarchy all the way and select the
last bone in the tail. (If you prefer, use the Selection tool and click on the
bone in the Editor window.) Select the Inverse Kinematics tool (Tools palette).
Select the Move tool (Action palette) and turn on all axes. In the Editor
window, drag the bone about and the whole tail should play ball, the IK
constraints stopping the movement getting too out of hand. When you’ve
finished wagging the tail, return it to its initial state, either with Undo or by
reloading the scene.

And that’s the tail’s IK chain done! Keep in mind that you can use bones on all
kinds of objects, they are not just for things that have arms, legs and tails; you
could have cars playing football, for example. Before we forget, let’s sort out
the hierarchy (Tail needs to by a child of Body, for example) and give Body an
anchor property so that IK works properly for the legs and neck.

21 In the Object Manager, select Body and then the Function>New
Property>Anchor command. That makes the body an anchor. To prevent
parts from accidentally separating from the Body we need to link them.
We’ll use Body as the main object and link the other parts as sub-objects.
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22 Drag Neck, then Tail, on to Body in the Object Manager. Following this,
drag all four legs on to Body. We’ll keep the base separate, since in the
animation Dave is going to abandon this.

For a bit of fun, now that our body is anchored you might like to try dragging
the neck and legs with the IK tool selected. Make sure you save first! When
you’ve finished experimenting, reload the scene and get yourself ready for a bit
of texturing.

More on materials
1 Apply to Body the shiny red material. Apply to Neck our shiny black material.

For Tail, use the shiny tan material. (These are the materials we created for
the legs.)

2 Create a new shiny grey material (r50g50b50s100) with a highlight (w8h90).
Click on OK and give the material a suitable name. Apply this material to
Head.

Now for the ears. We’d really like to see some leathery folds on those ears. We
could use bump mapping, but, what the heck, let’s go a step further and use
displacement mapping. Displacement mapping actually moves surfaces before
they are drawn, whereas bump mapping simply changes the surface normals of
an object to give the impression of extra surface geometry.

3 Dave’s ears are grey leather, so create a grey material (r60g60b60s100) and
select the Displacement property. Go to the Displacement page, click the
File button, locate and open the file named “Bump13.tif” (it’s in Tex/Basics).
Set Strength to 100% and Maximum Height to 8. Click on OK. Give this
material a suitable name and apply it to EarRgt and EarLft.

Now then, how about we put a smile on Dave’s face? For this we’ll need to use
a painting program.

4 Load up the painting program of your choice and create an image that
looks similar to the example on the left. Our image is 140 x 140 pixels; we
used just two colours, red and white.

5 Create a new material. On the Colour page, click the File button and open
the face image we’ve just created. Change the Colour S value to 0. Now
give the material a little highlight (w15h50). Click on OK and give this
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material a suitable name. Then (without holding down the Shift key so that
we get the Texture dialog) apply the material to Nose.

6 In the Texture dialog, change Projection to Flat, deselect the Tile option,
and change the H value to 90, which will rotate the heading of the texture
(the image) by 90 degrees so that Dave isn’t staring sideways. Click on OK
to confirm the changes and close the Texture dialog.

7 Select Texture>Adapt To>Object.

The eyes
We want Dave’s eyes to pop out when he sees that the base is on fire. If we use
a sphere for each eye we will be able to apply Free Form Deformation (FFD) to
stretch the eyes without affecting the rest of the face. An FFD is a cuboid or
“cage” of magnet-like points. By moving some or all of these points to new
positions, we can create a deformation in relation to the original point positions.
When we then apply the FFD to an object, the points in the object that fall
within the FFD cage will be deformed in line with how the points of the FFD
cage have been moved.

We’re going to use an FFD cage for each eyeball, enabling us to make Dave’s
eyes pop out so easily that your eyes may well pop out at the realisation of how
easy it is! First we need some eyeballs.

1 Select Objects>3D-Object>Surface Sphere. Change the name to EyeRgt,
set Radius to 20, then click on OK.

We’ll position the eyeball by hand, using the Move tool. We’ll need to exercise
a little judgement here to position the eyeballs correctly, but this will be made
easier for us if we work in the 4T view, turning on Flat Shading in the 3D view.

2 Press the Display button (View palette) and from the pop-up menu select
Flat Shading.

With shading selected, it will be  easier for us to judge the position of the eyes.

3 Select the Move tool (Action palette) and the Model tool (Tools palette).
Ensure that EyeRgt is selected in the Object Manager. Using all four views
to help you locate the position of the eye in the scene, move the eye to a
suitable place on Dave’s head. Turn off any axes if this helps.

4 … For Dave’s face, use a painting program
to create an image similar to this. It doesn’t

have to be a masterpiece, we used an
airbrush tool and three sweeps of the mouse.

3 … When positioning objects by hand, the
task is almost always made easier if you

utilise all four views, locking and unlocking
axes as necessary.
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We will use a smaller sphere to create the pupil. Instead of creating one from
scratch, let’s copy the eye and then scale it.

4 Select EyeRgt in the Object Manager, then select Edit>Copy, followed by
Edit>Paste. A new object named EyeRgt.1 will be created—an exact copy
of EyeRgt, right down to its position in the scene, so you won’t see anything
different the Editor window because the copy is occupying exactly the same
space as the original. Double-click on the name EyeRgt.1 and rename this
new sphere to PupRgt.

5 Ensure that PupRgt is selected in the Object Manager and that the Model
tool (Tools palette) is selected. Using the Coordinates Manager, change all
three Size values (X,Y,Z) to 16. (Ensure that the middle column of the
Coordinates Manager is set for Size, not for Scale.)

6 Apply the shiny black texture to the pupil. Ensure that the Move tool (Action
palette) is selected. Using the 4T view to aid location, move the pupil into
a suitable position. Do some test renders and reposition the pupil until
you are satisfied.

7 In the Object Manager, drop PupRgt on to EyeRgt to make the pupil a child
of the eye.

Since Dave’s face should be symmetrical, with the line of symmetry running
along the Z axis, we can create the left eye by copying the right eye (including
the pupil), renaming it, then changing its Z Position value in the Coordinates
Manager.

8 Ensure that EyeRgt is selected in the Object Manager, then select Edit>Copy
followed by Edit>Paste. Rename EyeRgt.1 to EyeLft. Click on the hierarchy
symbol for EyeLft, then change the name of its sub-object (PupRgt) to PupLft.

9 Ensure that EyeLft is selected in the Object Manager. In the Coordinates
Manager, delete the minus sign for the Position Z value (thus making the
value a positive one) and Apply.

The left eye should now be in position perfectly—assuming, that is, that the
right eye was in the perfect position to start with!

10 Create a shiny white material and apply it to EyeRgt and EyeLft.

6 … While you’re modelling, feel free to
zoom in and out or adjust your viewpoint at

any time.
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Free form deformation
Now to prepare the ground for the animation of the eyes. To accomplish the
effect we are after, we’ll use an FFD cage for each eye.

1 Select Objects>FFD Object. In the dialog that opens, change the name to
FFDEyeRgt. For the Grid Points, set X to 3, Y to 2 and Z to 2. For the Grid
Length, set X to 30, Y to 50 and Z to 50. Click on OK.

Now we need to position the FFD over the right-hand eye. We need to position
the cage accurately since we want to pull out only the front-facing portion of
the eye. We’ll probably find this easier to do by hand, rather than with the
Coordinates Manager.

2 Ensure that FFDEyeRgt is selected in the Object Manager and that the Move
tool (Action palette) is selected. Using all four views (it will be impossible
to position the cage using just one view) position the FFD cage over the
eyeball—refer to the illustration on the right to assist you.

To make the eyes pop-out we are going to use morphed FFDs, so we need to
create a Morph track in the Time Line. In order to create a Morph track we
need two FFDs. First we need the FFD to be morphed, then we need the
deformed FFD. When we apply the morph, CINEMA 4D will create a animation
that morphs from the shape of the original FFD cage to the shape of the deformed
FFD cage. But as this operation is irreversible, we will start from a copy of the
original FFD so that if we make a mistake we can start over without having to
create the FFD again.

3 Make a copy of FFDEyeRgt. Rename the copy to FFDEyeCopy. Note that we
have not used Rgt within the name—the positions of the copy and the
deformed FFDs are irrelevant here, so we can use the same copy and
deformed FFDs for both eyes.

4 Make a copy of FFDEyeRgt. Rename the copy to FFDEyeMorph.

To create the deformed FFD we will select a plane of points and drag these
away from the eye. This will cause the affected points to bulge in the direction
of the move. But first we will drag the FFD that we are going to deform on to
the eye object so that we can see the bulge as we drag out the points of the
FFD cage.

1 … The values entered into the FFD Object
dialog decide the size of the cage and how

many grid points that cage will contain.

2 … Position the FFD cage over the eyeball
so that it completely surrounds it, like so.
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5 In the Object Manager, drag-and-drop FFDEyeMorph on to EyeRgt to apply
the FFD cage to the EyeRgt object.

6 Switch views to the XY (front) view. Ensure that FFDEyeMorph is selected in
the Object Manager and select the Points tool (Tools palette). Using the
Select Element tool (Action palette), drag a box around the points of the
FFD cage that are to the right of the eye. The selected points will turn
orange. Select the Move tool (Action palette), then drag the mouse in the X
direction (to the right) until you are pleased with the bulge. Avoid bulging
the eye too far past the nose.

Now that we are happy with the morphed FFD, we need to remove it from the
EyeRgt hierarchy.

7 In the Object Manager, drag FFDEyeMorph into an empty space—that is,
remove it from the EyeRgt hierarchy.

We do, however, want FFDEyeRgt (the non-deformed cage) to be a sub-object
of EyeRgt because it is this original FFD that is to be morphed.

8 In the Object Manager, drag-and-drop FFDEyeRgt on to EyeRgt.

We will set up the actual morph animation later when we look at the Time
Line. For now, we simply copy FFDEyeRgt, rename it FFDEyeLft, then change
the Position Z value.

9 In the Object Manager, make a copy of FFDEyeRgt. Rename the newly
generated object FFDEyeLft.

10 Select FFDEyeLft in the Object Manager. Select the Model tool (Tools palette),
then use the Coordinates Manager to change the Position Z value from
negative to positive. For example, if Position Z is -25.25, change it to 25.25.
Click on Apply.

FFDEyeLft should now be position over the left eye. To apply the FFD cage to
the eye we need to make FFDEyeLft a sub-object of EyeLft.

11 In the Object Manager, drag-and-drop FFDEyeLft on to EyeLft.

6 … When we stretch the FFD cage, the grid
points attract the points of the eyeball

sphere, thus producing a bulge.
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Congratulations! We’ve finished the most difficult part of the FFD section. We
think you’ll agree that it wasn’t at all that difficult! We are getting close to
creating the animation itself, but there’s still a little preparation left—the fire
and the smoke.

Making fire
To create the fire we’ll place a cylinder around the donkey’s base. It will be a
little wider than the base, and we’ll use the mighty fire 2D shader (procedural
texture). This fire texture is already animated for us, so, when we render, it will
spring to life with flames breathing across the cylinder without us having to do
a thing.

1 Select Objects>3D-Object>Cylinder. Change the name to FireCyl. Set
Radius to 150, Height to 300, deselect Cover Ends, click OK.

Now we shall position the cylinder of fire around the base. Since the bottom of
the base rests on the Y=0 line, but is centred along the Z and X axes, a little
simple maths tells us that the cylinder should be positioned at (0,150,0).

2 Ensure that FireCyl is selected in the Object Manager and that the Model
tool (Tools palette) is selected. Use the Coordinates Manager to change the
Position X, Y and Z values to 0, 150 and 0 respectively, then click OK.

Now for the fire material.

3 Create a new material and name it Fire. Double-click on Fire to open the
Edit Material dialog. Click on File and open the file named “Fire.shc” from
the Tex/2D-Shader folder. Click the Edit button to open the Fire 2D-Shader
dialog. Notice that there are values you can change which alter the
appearance of the fire. The default settings are fine for our purposes, so
click OK to return to the Edit Material dialog. Slide the Colour strength
down to 0 so that we can see the fire in the material preview (top right of
the dialog).

The fire 2D shader creates bright flames on a black background. We are going
to apply this texture to the cylinder which surrounds the base and donkey, so
we’ll want to get rid of the black sections of the texture so that the base and the
donkey can be seen behind the fire. We can do this with genlocking, which has
the effect of making an object not exist in the areas of the covering texture that

2 … After positioning the fire cylinder it
should completely surround the base and

donkey (see below).
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are the genlocked colour. While we’re at it, let’s make the flames slightly
transparent, as they are in real life.

4 Still in the fire texture’s Edit Material dialog, select the Transparency and
Genlocking options. On the Transparency page, open the “Fire.shc” file
again. Set the strength of the Colour to 20 and the strength of the Texture
to 100.

5 Switch to the genlocking page. Once again, click on File and open “Fire.shc”
as the texture. Click on a black area of the fire texture preview. The black
areas will then disappear in the material preview (top right of dialog). We
have finished creating the fire material, so click on OK.

6 Drag the Fire material on to FireCyl in the Object Manager. In the Texture
dialog that opens, change Projection to Cylindrical and click OK. With FireCyl
still selected in the Object Manager, select the Texture>Adapt To>Object
command. This will adjust the texture to fit snugly around the fire cylinder.
Zoom in and render in the XY view to check the fire.

OK, the fire cylinder works, but it is obstructing the donkey somewhat and this
may get in the way when we animate him. We can use a display property to
hide the fire cylinder in the Editor window, yet still have it render.

7 With FireCyl selected in the Object Manager, select Function>New
Property>Display. Select the Hide In Editor property, but deselect Hide
When In Raytracer.

The fire cylinder is now invisible in the editor, but it will appear when rendered.
That takes care of the fire.

Creating smoke
What we are going to do is use something called an emitter to throw out lights.
These lights won’t actually be radiating any light, but they will be visible lights
that contain visible dust—that dust will be the smoke. We’ll use a turbulence
modifier to swirl the smoke.

So let’s create the light source. We require visible light (for the dust), but the
light does not have to illuminate the scene, therefore we can save lots of time
when rendering if we turn off light radiation.

6 … We use the Texture>Adapt To>Object
command to make the fire texture wrap

around the entire cylinder and cover it from
top to bottom.
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1 Select Objects>Scene Object>Light and name the light SmokeParticle.
Make the light a dark shade of grey (r40g40b40s100) since that’s what
colour smoke is.

2 Select the No Light Radiation property since we don’t want our light to
shine.

3 On the Visible Light page, set Density to XYZ Decreasing. This will give us
spherical particles; if, for example, we set it to XY Decreasing the particles
would be infinitely long along the Z axis, a bit like a laser beam, which
would not be particularly useful for generating a smoke effect.

4 Set the X, Y and Z radii to 50m each. This will allow the dust (smoke) to
spread out that distance in each direction.

5 Set Brightness to 0% because we don’t want our visible light to shine. If we
set, for example, a Brightness of 50%, our smoke will be a very light grey
instead of the dark grey that we want.

6 Set Dust to 50%. The higher this value, the dustier the light (the thicker our
smoke will be).

7 Leave Rate set to 10. The lower this value, the further the visible light (and
thus our smoke) will extend from the source. If we set this too low we’ll
end up with very sooty smoke indeed.

8 We have finished defining the light source, so click OK.

Now we need an emitter to generate the smoke particles.

9 Select Objects>Particle System>Emitter and name the emitter
SmokeEmitter.

10 Set Birth Rate (Editor) to 50. This is how many objects per second the
emitter will emit in the Editor window. It’s a good idea to keep this low to
speed up screen refresh. This setting does not affect the final render, just
the display in the Editor window (see below).

11 Set Birth Rate (Rend.) to 120. This is how many objects (smoke particles)
the emitter will emit per second in the render.

2 … Ensure that you select the No Light
Radiation option, otherwise our smoke is

going to shine.

3-7 … Most of the Visible Light settings will
have an effect on the appearance of our

smoke—you might like to experiment here.
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12 Set Lifetime to 200. This is the number of frames for which each emitted
particle will “live” from the time it is emitted.

13 Speed to 400. This is how fast the particles will move (in current units per
second).

14 Set Speed Variation to 10%. This will make our particles slow and quicken
by 40 units per second. If we leave this at zero, our smoke will rise at a
uniform speed and will look rather artificial.

15 On the Emitter page, set the X length to 220 and the Y length to 220. This
is the size of the emitter, meaning that particles will be generated randomly
from anywhere within the entire area of this plane.

16 That’s our emitter set up, so click OK to create it.

Since objects are always generated at the world origin (0,0,0), the emitter is
created exactly where we want it, except that we need to change the direction
in which its Z axis is pointing  because emitters always emit particles in that
direction.

17 Ensure that SmokeEmitter is selected in the Object Manager and that the
Model tool (Tools palette) is selected. Using the Coordinates Manager,
change the P value to 90 to rotate the pitch of the emitter by that many
degrees.

Now we need to tell the emitter what to emit. (If we neglect to do this, emitters
will simply emit a default particle.)

18 In the Object Manager, drag-and-drop SmokeParticle on to SmokeEmitter.

Now to add some turbulence to the smoke.

19 Select Objects>Particle System>Turbulence and name it SmokeTurbulence.

20 Set Strength to 5 for just a little bit of turbulence.

21 Set the sizes to X=500, Y=1200, Z=500; these are the distances (in current
units) over which the turbulence has an effect.

9-14 … You can have some real fun and
games in here. Well worth coming back later
and experimenting with each of the settings

in turn.

15 … On this page you set the type and size
of the emitter plus the angle at which

particles will be emitted.

19-22 … To make the passage of our smoke
a little less uniform, let’s add some

turbulence.
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22 That’s the turbulence set up, so click OK.

We want our turbulence object to sit on the floor, so we need to adjust its Y
position.

23 With Turbulence selected in the Object Manager and the Model tool selected
(Tools palette), use the Coordinates Manager to change the Position Y value
of SmokeTurbulence to 600.

The turbulence object should now be surrounding the donkey and fire cylinder.
Before we progress to the animation proper, let’s just check that smoke effect.

24 Change to the XY view (View palette). In the Time Manager, drag the frame
pointer to about frame 100 then select the Render in Editor Window tool
(View palette).

Do not be concerned if the smoke has missing bands of particles in the Editor
window. If this happens it will be due to the speed optimisations that allow
realtime feedback in the Editor. When we render the animation in an external
(new) window our smoke will be unbroken.

Tidying up
Right. Before we go for the animation, we need to tidy up a little.

1 In the Object Manager, drag-and-drop EyeRgt on to Head, then EyeLft on
to Head, so that the eyes are now children of the head and thus will stay in
the head when the head moves.

2 Still in the Object Manager, select Function>Group Objects and drag a
box over SmokeTurbulence, SmokeEmitter and FireCyl. These three objects
will then be placed into a single group. Rename that group Fire-Smoke.

Animation
OK, we have used bones to create the tail, we have applied IK to the tail, neck
and legs, we have added FFD cages to the eyes, we have used 2D textures, we
have even created smoke. With the majority of the donkey work behind us, we
now glide elegantly into the world of animation. Our chief tools here will be
the Time Manager and the Time Line.

23 … The turbulence object should
completely surround our model.

24 … Now Dave’s in serious trouble!
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But before we think of creating even a single key frame, we must ensure that
we are clear about the plot. Every action involves a new key frame, and every
action should be considered and planned.

Dave will start life in his modelled position. His tail will wag nonchalantly for a
brief period, while at the same time the smoke rises and the fire rages away.
(Stupid donkey!) Now then, we do not require key frames for the smoke or fire
as these objects will be animated by CINEMA 4D, but we will require key
frames for the tail movement.

After a while, Dave (who is now beginning to feel unseasonably warm) will look
down at the fire. We will need key frames for the neck movement here. When
he looks down Dave will raise his tail (cos that’s what donkeys do), so we will
require further tail key frames for this.

After a brief pause while Dave’s slow brain registers the situation in which we
have placed him, his eyes will bulge out in horror. For this effect we will require
(in the Time Line) morph sequences for the FFD cages.

Now terrified (but still wearing that stupid grin), Dave will jump out of the
scene. This is the most complex section of animation since the legs, neck, tail
and body will all require keys. To make Dave jump we’ll first raise his neck to
its starting position (he’s still looking down at this juncture, remember), then set
a key frame with him crouched, followed by two further key frames with him
leaping through the air and out of the scene. Thanks to IK and bones, all this
movement, which appears to be quite complex, is actually very easy to achieve.

To ensure smooth playback for all of the above, we will set a playback rate of
30 frames per second (fps).

OK, enough plotting, let’s go for it. We will try to avoid creating more key
frames than are strictly necessary—fewer keys are easier to understand and
easier to move. Ensure that you have saved the scene before starting this section.

1 In the Time Manager, drag the frame slider to frame 0. Select the Position,
Direction and Sub-Objects options, but deselect the Size option.

2 In the Object Manager, select Body, then click Record in the Time Manager.
Remember that the Record button works only when the Time Manager is
the active window. If you have just clicked in the Object Manager to select
Body, then you will need to click once in the Time manager to activate that
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window, then click Record to record the key frame. If in doubt, click Record
again to ensure that a key frame has been recorded at frame 0.

Having meticulously planned the animation, we know that there are two
instances later in the animation when the body is in the same state as the initial
position: frames 30 and 130. So before we animate we’ll save effort by recording
those frames now.

3 Ensure that Body is selected in the Object Manager. Then, in the Time
Manager, move the pointer to frame 30 and click Record. Next, move the
pointer to frame 130 and click Record again.

We have now set key frames for all the objects in the body at frames 0, 30 and
130. We now want to wag the tail between frames 0 and 30. We’ll accomplish
this by generating new key frames for the tail at frame 7 and frame 22.

4 In the Time Manager, drag the frame pointer to frame 7. In the Object
Manager, select the deepest (the right-most) child tail bone. With the Move
tool (Action palette) selected, and with the Inverse Kinematics tool (View
palette) selected, use the 4T view to move the tail to the donkey’s lower
right. Once the tail is in position, select the parent object (Tail) in the Object
Manager, then click Record in the Time Manager.

5 In the Time Manager, drag the frame pointer to frame 22. In the Object
manager, select the deepest child tail bone. With the Move and Inverse
Kinematics tools selected, use the 4T view to move the tail to the donkey’s
lower left. Once the tail is in position, select the parent object (Tail) in the
Object Manager, then click Record in the Time Manager.

6 Click the Play button in the Time Manager.

The tail should wag between frames 0 and 30. Already the animation is taking
shape. The next part involves making the donkey look down at the fire. To do
this we need to animate the neck with IK. Since we saved keys for all the body,
we already have a key for the neck at frame 30 (Neck being a child of Body) so
we can proceed directly to creating a key frame at 60 with the neck in the bent
position.

7 In the Time Manager, move the pointer to frame 60. Select Neck in the
Object Manager. Ensure that the Inverse Kinematics and Move tools are
selected. Now drag the mouse until the donkey is staring down at the fire.

4 … At frame 7, with the tail moved out to
the donkey’s right, click Record in the Time

Manager.

5 … At frame 22, with the tail moved over to
the donkey’s left, click Record in the Time

Manager.
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We need to create a key only for Neck. In accordance with the rule of hierarchy,
the children (sub-objects) follow the parent—where the parent goes, the children
follow. So in our case, the head, nose, ears and eyes move with the neck since
they are children of the neck.

8 In the Time Manager, deselect the Sub-Objects option (to save creating
unnecessary keys for all of Neck’s children). Ensure that Neck is selected in
the Object Manager, then click on Record in the Time Manager (which
should be at frame 60). This has recorded a key frame with the neck in its
bent position.

The neck remains bent until frame 110, so we need to record a key for the bent
neck again at this frame.

9 In the Object Manager, ensure that Neck is selected. Move the frame pointer
in the Time Manager to frame 110, bend the neck again so that the donkey
stares at the fire, then click Record.

Animating the eyes
We want the eyes to start bulging at frame 70, reach maximum bulge at frame
80, remain at maximum until frame 90, then return to normal by frame 100.

The bulge is achieved with morph sequence. To create a morph sequence we
need to work in the Time Line.

1 Open the Time Line window if it is not already open (Window>Time Line).

2 In the Time Line window, select FFDEyeRgt and then select the
Function>New Track>Special Effects>Morph command. A Morphing track
for FFDEyeRgt will appear in the Time Line.

3 With that Morphing track selected, use the Function>New Sequence
command to open the Sequence dialog. Set From to 70, and set To to 100.
Click OK.

4 With the Ctrl key held down, click at the start of the Morphing sequence
(the left-hand edge of the red line, about frame 70) to create a key at this
frame. The Morph dialog will open and you will be prompted for a name.
Enter FFDEyeCopy (the eye at minimum bulge) and click OK.

7-8 … At frame 60, with Dave’s head
bowed, click Record in the Time Manager.

3 … Our bulging eyes sequence will start at
frame 70 and end at frame 100.
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5 Crtl-click at about frame 80 of the sequence. This time, enter FFDEyeMorph
(the eye at maximum bulge) for the search name. Click OK.

6 Ctrl-click at about frame 90 of the sequence. Since we want this frame to
be the same as frame 80 (so that the maximum bulge is held for about 10
frames), enter FFDEyeMorph again as the search name. Click OK.

7 Ctrl-click at about frame 100 of the sequence. This time, enter FFDEyeCopy
(the eye at minimum bulge) and click OK.

OK, as we have completed the FFD morph for the right eye we can now simply
copy this morphing track for the left eye.

8 In the Time Line, hold down Ctrl and drag the Morphing track (the actual
name “Morphing”, not the red line) from FFDEyeRgt and drop it on
FFDEyeLft.

Since FFDEyeRgt and FFDEyeLft use the same copy and morph FFDs, we do
not need to change the names in the keys!

9 Press the Play button in the Time Manager (with fps set low, 10fps for
example), and in the Editor window you should see the eyes bulging out
and back in between frames 70 and 100.

The crouch
Frame 130 sees the donkey back to its original position. By frame 150 we want
him coiled back, ready to leap into the air. For a dynamic pose we want the tail
arched and the front legs bent in towards the body. The neck can crane forward
a little. (Hi-ho Dave and away, cue the William Tell Overture.)

To attain the crouch position we will need to bend Dave’s legs upwards, which
means they’ll come away from the base. To ensure that we place the rear hooves
back in the correct positions (the front pair will be left in the air), we can place
a couple of dummy markers which we will delete as soon as they have served
their purpose, which is to ensure that we reposition the rear hooves correctly.

1 In the Time Manager, move the frame pointer to frame 150, which is where
all this action is going to start.

4-7 … The only thing you need to enter into
the Morph dialog is the name of the object to

which the Morph is to be applied.
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2 Select Objects>3D-Object>Cylinder. Name the object DummyRgt, set
Radius to 15, Height to 30, click OK.

3 Ensuring that DummyRgt is selected in the Object Manager, select the Model
and Move tools. Now, in the Editor window drag DummyRgt to the same
position in the scene as the donkey’s right back hoof. Use all the views to
assist you in correctly positioning the dummy.

Remembering that the donkey has symmetry along the Z axis, we can now
create the left hoof dummy by simply copying the existing dummy and making
the Z position value positive.

4 In the Object Manager, create a copy of DummyRgt and rename the copy
DummyLft. With DummyLft still selected in the Object Manager, ensure
that the Model tool is selected and use the Coordinates Manager to change
the Position Z value from negative to positive. For example, if Position Z is
-26.25, change it to 26.25.

Now that these markers are in place, we can move the legs and body about,
safe in the knowledge that the markers will guide us when we want to relocate
the donkey on the base.

5 Select HofBckRgt in the Object Manager, then select the Inverse Kinematics
and Move tools. In the Editor window, drag the mouse to move the right
hoof (and thus the whole right leg) backwards into a bent position that will
be suitable for the crouch.

6 Select HofBckLFt in the Object Manager, then select the Inverse Kinematics
and Move tools. In the Editor window, drag the mouse to move the left
hoof (and thus the whole left leg) backwards into a bent position that
matches the crouch of the right leg.

Now to put the hooves back on the base. First we will rotate the body so that
the bottom of the rear hooves are parallel to the top of the base, then we will
move the body into position.

7 Select Body in the Object Manager and select the Rotate tool. Turn off the
X and Y axes, turn on the Z axis. Rotate the body by dragging the mouse in
the Editor window; under Windows hold down the right mouse button
and drag left, under Mac OS hold down the command key and the mouse
button, and drag left. Rotate it until the bottom of the rear hooves are
parallel to the top of the base.

5 … This is the kind of position Dave’s legs
need to be in for the crouch. (Note the

dummy marker we have positioned so that
we can put the hooves back exactly where

they started, otherwise the animation is
going to jerk at this point.)

7 … Before putting Dave’s hooves back on
the base we need to rotate the entire model
about the Z axis until the hooves are once

again parallel with the base.
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Now we need to move the body until the rear hooves are in the same positions
as the dummy hooves.

8 With Body still selected in the Object Manager, select the Move and World
Coordinate System tools, turn on the X and Y axes, turn off the Z axis. In
the Editor window, drag the mouse until the hooves are in the same
positions as the dummies. Use the 4T View to ensure that the position is
correct.

9 We can now delete the dummy hooves, they have served their purpose.
Select them in the Object Manager and use the Edit>Delete command.

The crouch position is taking shape. The neck needs to bend forward somewhat,
and the tail still needs to be raised.

10 Select Neck in the Object Manager. Select the Inverse Kinematics and Move
tools. Ensure that all the axes are turned on. In the Editor window, drag the
mouse to move the neck forward a little, perhaps until the neck points
straight up.

To move the tail with IK, we need to select the end tail bone.

11 In the Object Manager, select the deepest bone child for the tail (the bone
that is right-most when the tail hierarchy is fully opened). Ensure that the
Inverse Kinematics and Move tools are selected, and that all three axes are
turned on. In the Editor window, drag the mouse to move the tail upwards.

Now let’s bend the front legs.

12 Select the front hoof in the Object Manager, select the Inverse Kinematics
and Move tools, and position the front legs in a similar fashion to the legs
in the illustration to the left.

Well done! The donkey is now in a position for us to record a key frame at
frame 150. Since we have moved so many bits for this frame, we can save
ourselves a lot of work by creating a key frame for the Body object, which
(provided Sub-Objects is selected in the Time Manager), will automatically create
the key frames for every child of Body. Although this creates some unnecessary
key frames for objects that have not changed, the alternative (creating key frames
for each object we moved, one by one) is too laborious to even think about.

8 … Use all four views to reposition Dave’s
rear hooves in the exact positions of the

dummy markers.

10 … Dave’s neck needs to be set upright.

11 … In the crouch position, Dave’s tail will
look better if it is raised.

12 … The last step for the crouch pose is to
move Dave’s front legs into this position.
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13 Select Body in the Object Manager. In the Time Manager, ensure that
Position, Direction and Sub-0bjects are selected. Ensuring that the Time
Manager window is the active window, click Record.

The leap
We’re almost done. We need a couple more key frames, one towards the
beginning of the donkey’s leap, a second when he will be out of the scene
come the final render. (We’ll worry about the camera position later.)

1 Move the frame pointer in the Time Manager to frame 160. Using the
same techniques described in the previous section, move the tail, neck
and legs with the IK tool, then the body as a whole with the Move tool, to
the approximate positions illustrated to the left.

2 With the body in position, select Body in the Object Manager then click on
Record in the Time Manager (ensuring that Sub-Objects is selected).

OK. The next stage comes at frame 200, where we need the donkey far away
from the base. We simply need to move the entire body with the Move tool,
then rotate it a little.

3 In the Time Manager, move the frame pointer to frame 200. Ensure that
Body is selected in the Object Manager. Move and rotate the body to the
approximate position illustrated to the left.

4 Select Body in the Object Manager, then click on Record in the Time Manager
(ensure that Sub-Objects is selected).

Camera angle
We want a better camera position than the default one.

1 Select the Camera tool.

2 Using the Move and Rotate tools as necessary, drag the mouse until you
have a view (in the 3D view) which you feel is suitable.

When selecting a camera angle for this animation, keep in mind that we’d like
the donkey leaping out of the scene by frame 200 (so it’ll help if the camera is
in front of rather than behind the donkey), we would like a glimpse of the eyes

1 … For the start of the leap, at frame 160
we need to manipulate Dave into a position

that looks something like this.

3 … At the end of the animation (frame 200)
Dave needs to be some distance from the

base so that he leaps out of the scene.
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as they pop out (so don’t raise the camera too high), and we would like to see
the clouds too.

To help you choose a good camera position, use the Time Manager to play
through the animation in the Editor window—try switching the view to Skeleton
view (click the View tool) and using a playback rate of 10fps. If Dave’s leap is
too slow, move him further away from the base and re-record the key frame for
the Body at frame 200.

The render
Once you are satisfied with the camera position, we need to set the render
preferences.

1 Select File>Preferences>Render.

2 Ensure that Render Mode is set to Raytracer.

3 Set Antialiasing to None—antialiasing would smooth the edges, but it is
not critical for our test animation. You can try turning it on later to check
the benefits.

4 Set Transparency to No Refraction.

Don’t click OK yet, we need to set some preferences on the Output and Save
pages first.

5 Switch to the Output page.

6 Set Resolution to 320x240—the higher you set the resolution, the longer it
will take to render our animation!

7 Set Frame to All Frames.

8 Frame Rate should be set to 30.

Don’t click OK just yet, we still have the Save page to attend to.

9 Switch to the Save page.

2-4 … These settings will not produce the
best output in the world—for our first render
of the complete animation we need to strike
a balance between quality and speed. If you

are happy with your animation, you can
always come back here later and add

antialiasing, oversampling and shadows.

5-8 … For our first render of the animation,
let’s set a low resolution.

2 … If you adjust your camera position so
that Dave is oriented something like this, you
won’t be far away from the best camera angle

for this animation.
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10 Set the format to MOVIE Medium Compression (PowerMac) or AVI Medium
Compression (Windows 95/NT).

11 Set Colours to 24 Bit (16 Million).

12 Click the Path button and select a destination folder and name for the
movie.

13 Click OK to set our render preferences. (These, by the way, will be saved
with the scene.)

We are now ready to render the movie! (Might be an idea to save first.) It’s a
fairly big animation we have here, it’s going to take a while to render every
frame. Exactly how long will depend on a number of factors, including the
performance of your machine. Even on a very fast machine, we’re talking at
least hours here so, because we’ve got 200 frames to raytrace, perhaps you’d
like to cook it overnight.

14 Click on the Render Scene In External Window tool. This will open a window
in which a preview will be rendered (so you can see how it’s cooking),
while at the same time saving the movie in the file named on the Save
page of the render preferences.

Once the movie is completely rendered, double-click its icon to play it.

So that’s it. The hard work is over and the fun starts. Go back and change a few
things. Now that the scene is complete, you will be amazed at how easy it is to
make alterations and improve on our work.

9-12 … Once again, setting medium
compression for the movie format strikes a

balance between speed and quality.
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WHAT NOW?
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FORWARDS!
Congratulations on completing the tutorials! The burning question now,
particularly for the less-experienced, is: “How do I become a 3D expert?”

Absorb the tutorials
To start with, ensure that you derive maximum benefit from the tutorials. This
means going back and changing things. For the donkey scene, how about
adjusting the IK for the neck so that the head can look left and right? Maybe
you can rewrite the entire animation sequence and have the donkey run out of
the scene rather than jump. If you are an experienced 3D artist, we thoroughly
recommend blowing up the base using an explosion special effect track, but
please make sure that Dave the Donkey comes out of it unscathed!

Another book
CINEMA 4D’s reference manual cannot possibly teach you all there is to know
about 3D. There are dozens of helpful books on the subject and we recommend
that you invest in at least one of these. Please consult the recommended reading
section in the reference manual for suggestions.

Read the reference manual from cover to cover
Great benefit can be derived by rapidly working though the reference manual—
you’ll have a better awareness of the tools available to you, so you’ll be better
equipped full-stop.

Study the model subject
If you want to design a space ship, your first ever, look at similar models and
pictures created by other professional artists. This will put you on to the right
track straight away. Think about how you would change the design in line with
your taste. Professional artists often have models lying around on desks and
shelves— Millenium Falcon, Tyrannosaurus Rex, the odd Ferrari or three...

3D periodicals
Graphics magazines can help a lot. Keep an eye open for tutorials. Look at the
effects being created by other 3D artists. Keep a finger on the pulse of 3D.
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Internet
The Internet is increasingly changing the way we work and play. Be sure to
check the CINEMA 4D web sites for galleries, tutorials and support sites.

Be inspired
Thank you for taking the time to read this book and follow along with the
tutorials. We are not going to wish you luck, instead we wish you swift
inspirations.
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